On 06/25/2012 06:46 PM, hagadur wrote:
> This was in different forum, had to move it here. Take a look at the
> problem below.
> Interstingly we took care of java memory and for the Admin the roles
> status says "Running: New Request". I synchronized "Roles and Resource
> drivers" and restarted the drivers but still the same issue.
> Any ideas why this might be?
> On 6/25/2012 10:00 AM, David Gersic wrote:
>> On Fri, 22 Jun 2012 16:36:01 +0000, hagadur wrote:
>>> I installed User App 4.0.1 and when i login as Admin, I am not able

> to
>>> see 'Manage' button feature on the Work Dashboard.

>> UserApp has its own forum, so you might be better off asking there.
>>> This use has Admin
>>> rights and is able to access Administration Tad. How to enable this
>>> feature for a user?

>> During the installation, you have to nominate an application
>> administrator. You probably didn't nominate "Admin" there. You can
>> probably fix this in configupdate.

> Agreed, the right people read the other forum.
> However, I think David is correct, sort of, but misses an important
> point.
> UserApp really has two different admin permission sets.
> 1) Very first admin user you specify first time only, when installing
> the UA and the DB. This is special, and precious.
> You can add more User App Admins, but you cannot really do anything to
> change this special one. I have no clue where it is stored or how to
> change anything about it.
> 2) Usually the exact same user, gets a bunch of UA/RBPM roles assigned
> that are all about rights to stuff within the User App itself. (It has
> its own rights model, using Roles from RBPM). In the 4.01 UA there is
> a
> button in ConfigUpdate I am told, that re-requests setting these
> roles.
> Lots of discussion on how this aspect can go wrong here:
> http://www.novell.com/communities/no...administrators

This typically happens because the User you want the Roles to be
assigned to, is not within the scope of the Role Resource Service
Driver. Make sure the user is within the scope as outlined by the
setting "User Group Container DN" on the RRSD.

Steven Williams
Lead Software Engineer