I have installed the 3.7 version of the user app with xdas logging
enabled during the install. Configured openxdas, unixodbc and freetds.
Everything works as expected. Has been running in production for 3 years
with no issues.

New system:
I now have a new install of 4.0.1 B. installed without selecting
logging during the install. I now want to add xdas logging, and have
configured openxdas .8.351, unixodbc 3.2.0, and the Microsoft odbc
client for Linux v 11 (connecting to a SQL2012 server so I wasn't sure
the freetds was the best option now that MS has a driver that is 100%
I can connect OK to the SQL server using isql so I know the unixodbc
and driver is working. openxdas is configured to use that connection
string that was just tested with isql.

The test:
xdasd configured to start on boot - the xdasd.log shows xdasd starts
without an error and is in "main loop"
Using the the user app, I select xdas loggin option and the persist
option, it saves OK ( so it says) - In the server.log I see "openxdas
logging successfully initialized... Logging on to the user app should
now generate an event to log to xdas and I should see a connection to
the SQL server in the xdasd.log file (as witnessed in the 3.7 user app)
but I see nothing. No errors in the server.log. If I restart the user
app, the xdas logging is no longer selected...

My Question:
So, if I did not select the xdas logging option when installing, am I
missing something required to enable xdas logging? Reading the
administration guide it states to add xdas logging - 1) select it during
install, or 2) select it in the user app logging page. Because this is
not working I am suspecting I am missing some config \ lib because I did
not initially select it during the install plus the fact it it not
staying selected. (I swear I have read the need for it to be selected
during the install, but I cant find that in any of the documentation at
the moment)

Any help with this would be appreciated.

jml005's Profile:
View this thread: