I am obviously missing something very fundamental, but it is slowly
doing my head in.

I have set up the userapp (Identity Manager Roles Based Provisioning
Module Version 4.0.2) so that users can be edited by the service desk to
fix up issues such as manager and site.

Manager is an attribute of type dn and has dnlookup configured to use
entity user and lookup based on username or firstname or last name,
entity user for detail. Manager is set to be editable.
If I access it through the detail edit portlet I can select the dnlookup
button and type in something and it returns a list of users and I can
select one.

I tried the same with site, which is an auxiliary attr of type dn that
will eventually point to a locality object. Initially I tried a new
lookup entity but it was simply not working so I set it up to be exactly
the same as the manager attribute - using the same dnlookup settings.
In the edit portlet I get the dnlookup button and that brings up the
drop down atttr list and lets me type something, but when I select
search absolutely nothing happens.

I repeated the exercise with secretary and it works fine so it is
obviously something odd about auxiliary attributes, but I cannot work
out what piece of the puzzle I am missing.

Any pointers would be appreciated.


ETFKNOVL's Profile: https://forums.netiq.com/member.php?userid=3938
View this thread: https://forums.netiq.com/showthread.php?t=47600