Home

Results 1 to 6 of 6

Thread: how to resolve LocalizedEmailTemplateResolver locale error.

Hybrid View

  1. #1
    mayuri7788 NNTP User

    how to resolve LocalizedEmailTemplateResolver locale error.


    hi

    I have developed a workflow (designer 4.0.1)( imanager version 2.7.6)
    at the end of workflow termination error is coming. Workflow Error:
    com.novell.soa.common.i18n.LocalizedResourceResolv erNoDefaultFoundException:
    The resource resolver
    com.novell.soa.notification.impl.vdx.LocalizedEmai lTemplateResolver did
    not return a resource for the default locale of en. It is required that
    a resource exist for the default locale.

    I have deployed 2 email templates
    #1 is the name without a language

    #2 is the name with the default language for the User Application

    For Example:
    Provisioning Notification
    Provisioning Notification_en

    Also i tried with changing
    srvprvPreferredLocale attribute but its getting same error .

    All the form value have display label in english.

    Please suggest

    Thanks
    Mayuri


    --
    mayuri7788
    ------------------------------------------------------------------------
    mayuri7788's Profile: https://forums.netiq.com/member.php?userid=3701
    View this thread: https://forums.netiq.com/showthread.php?t=48246


  2. #2
    Steven Williams NNTP User

    Re: how to resolve LocalizedEmailTemplateResolver locale error.

    On 07/22/2013 09:34 AM, mayuri7788 wrote:
    >
    > hi
    >
    > I have developed a workflow (designer 4.0.1)( imanager version 2.7.6)
    > at the end of workflow termination error is coming. Workflow Error:
    > com.novell.soa.common.i18n.LocalizedResourceResolv erNoDefaultFoundException:
    > The resource resolver
    > com.novell.soa.notification.impl.vdx.LocalizedEmai lTemplateResolver did
    > not return a resource for the default locale of en. It is required that
    > a resource exist for the default locale.
    >
    > I have deployed 2 email templates
    > #1 is the name without a language
    >
    > #2 is the name with the default language for the User Application
    >
    > For Example:
    > Provisioning Notification
    > Provisioning Notification_en
    >
    > Also i tried with changing
    > srvprvPreferredLocale attribute but its getting same error .
    >
    > All the form value have display label in english.
    >
    > Please suggest
    >
    > Thanks
    > Mayuri
    >
    >

    Greetings,
    If the error is coming at the end then it would generally be the
    Finish Activities email template that is missing or not correct.

    Overall, you must have at least 2 email templates when you create a new
    one. The first will not have a language added to the name and the
    second must be default language of the User Application.

    Sometimes, after you have deployed from the Designer, it is necessary to
    restart the User Application for the change to be picked-up in this case.



    --

    Sincerely,
    Steven Williams
    Lead Software Engineer
    NetIQ

  3. #3
    mayuri7788 NNTP User

    Re: how to resolve LocalizedEmailTemplateResolver locale error.


    Thanks for reply.

    At the end email template is fine, i check there all tokens are mapped
    mail is also coming fine.

    Also i restarted User application but this also didn't worked .
    Default locale is also english. and there are 2 email templates

    Is this prob may be due to different version of designer or some patch
    issue ?

    mayuri


    --
    mayuri7788
    ------------------------------------------------------------------------
    mayuri7788's Profile: https://forums.netiq.com/member.php?userid=3701
    View this thread: https://forums.netiq.com/showthread.php?t=48246


  4. #4
    mjuricek NNTP User

    Re: how to resolve LocalizedEmailTemplateResolver locale error.


    Hi,
    i have the same issue in IDM 4.5 (integrated and standalone
    implementation scenario too).
    My requests are terminated with an error and I found the following error
    in the catalina.out:

    2015-03-27 08:12:46,563 [pool-6-thread-9] ERROR
    com.novell.soa.af.impl.LogEvent- [RBPM] [Workflow_Error] Initiated by
    cn=uaadmin,ou=sa,o=data, Error Message: c
    om.netiq.common.i18n.impl.LocalizedResourceResolve rNoDefaultFoundException:
    The resource resolver
    com.novell.soa.notification.impl.vdx.LocalizedEmai lTemplateRe
    solver did not return a resource for the default locale of en. It is
    required that a resource exist for the default locale., Process ID:
    e7c5f071d6ba429d9e0cf0
    90d8ac7455, Process Name: cn=Resource
    Provisioning,cn=RequestDefs,cn=AppConfig,cn=User Application
    Driver,cn=driverset1,o=system:10, Activity: Activity1, Recip
    ient: cn=mjuricek,ou=users,o=data

    I checked the Default Notification Collection and all
    (de,en,es,fr,it,ja,nl,pt,ru,sv,zh-CN,zh-TW) templates translations are
    there. (btw. I see these templates only in iManager. In the Designer I
    see default and en templates only)

    Any idea that is wrong?

    Thank you!
    Milan


    --
    mjuricek
    ------------------------------------------------------------------------
    mjuricek's Profile: https://forums.netiq.com/member.php?userid=1616
    View this thread: https://forums.netiq.com/showthread.php?t=48246


  5. #5
    Join Date
    Dec 2007
    Location
    Brooklyn, NY
    Posts
    6,213

    Re: how to resolve LocalizedEmailTemplateResolver locale error.

    On 3/27/2015 7:26 AM, mjuricek wrote:
    >
    > Hi,
    > i have the same issue in IDM 4.5 (integrated and standalone
    > implementation scenario too).
    > My requests are terminated with an error and I found the following error
    > in the catalina.out:
    >
    > 2015-03-27 08:12:46,563 [pool-6-thread-9] ERROR
    > com.novell.soa.af.impl.LogEvent- [RBPM] [Workflow_Error] Initiated by
    > cn=uaadmin,ou=sa,o=data, Error Message: c
    > om.netiq.common.i18n.impl.LocalizedResourceResolve rNoDefaultFoundException:
    > The resource resolver
    > com.novell.soa.notification.impl.vdx.LocalizedEmai lTemplateRe
    > solver did not return a resource for the default locale of en. It is
    > required that a resource exist for the default locale., Process ID:
    > e7c5f071d6ba429d9e0cf0
    > 90d8ac7455, Process Name: cn=Resource
    > Provisioning,cn=RequestDefs,cn=AppConfig,cn=User Application
    > Driver,cn=driverset1,o=system:10, Activity: Activity1, Recip
    > ient: cn=mjuricek,ou=users,o=data
    >
    > I checked the Default Notification Collection and all
    > (de,en,es,fr,it,ja,nl,pt,ru,sv,zh-CN,zh-TW) templates translations are
    > there. (btw. I see these templates only in iManager. In the Designer I
    > see default and en templates only)


    Right click in Designer on the Default Notification Template object,
    chose Edit Filter, and you will see by default only English is
    un-filtered. (That is un-possible!)

    Change that to see them in Designer.


  6. #6
    mjuricek NNTP User

    Re: how to resolve LocalizedEmailTemplateResolver locale error.


    thank you!
    and any idea how to solve an issue about workflow error?

    M.


    --
    mjuricek
    ------------------------------------------------------------------------
    mjuricek's Profile: https://forums.netiq.com/member.php?userid=1616
    View this thread: https://forums.netiq.com/showthread.php?t=48246


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •