Using IDVault.globalQuery and passing text through a parameter
containing a colon causes the underlying LDAP filter to be re-written
according to the log file.

Example (mail=SMTP:myname@myaddress.com) gets re-written to
(&(mail=SMTP*)(mail=myname@myaddress.com))

Leaving out the colon in the text passed through the parameter works
just fine.

Any ideas of how to escape the ':' so it is treated as the rest of the
text and not a special character?


--
rreid
------------------------------------------------------------------------
rreid's Profile: https://forums.netiq.com/member.php?userid=396
View this thread: https://forums.netiq.com/showthread.php?t=48834