I Tried asking the same question repeatedly in this forum regarding
delegation i didn't get any response.
When i try giving Provisioning Administrator role to a particular
group,When a user from that group raises a request it comes up in his
task notifications which in the ideal scenario shouldn't be,but when the
user clicks on the notification he finds an error.And for all the
workflows we are using the restrict view option(Restrict task list to
tasks initiated by the user).This works perfectly fine for other users
from other groups who not part of Provisioning Administrator role.

One more thing in the user application documentation it is specified
that for delegation you need to be part of atleast one of these roles
*Provisioning Administrator,Provisioning Manager or Team Manager.*When i
tried giving Provisioning Manager role to that group it doesn't allow
the user from that group to create a delegation assignment i.e.when i
try clicking on the new button for the delegation assignment it allows
me to enter all the details,after that when i try to click on submit it
throws an error that you should be an administrator to do this task,So
when i try to give provisioning administrator role i face the issue that
i've specified above along with that the user from that group will get
to see the administration tab(Which should be as we are giving him an
Administrator role),but the user from that group can try editing the
administrator assignments i.e he can either assign or remove
administrator assignments.
This shouldn't happen?

So can anyone help me on this?

Thanks and Regards
Vijay Deepak

vijaydeepak33's Profile: https://forums.netiq.com/member.php?userid=3319
View this thread: https://forums.netiq.com/showthread.php?t=48959