We are using Novell Identity Manager 4.0.2. We have been facing some
problems with the workflow delegation option and would appreciate any
suggestions on the issue. We have a Request Approver who receives
Approval Requests for a Workflow. We have another User who needs to be
the delegate of the Request Approver. When Request Appover is
Unavailable, the Workflow Approval requests need to go to the Delegate
User. Both users report to the same Manager. But the request seems to be
going to the Original Approver instead of the Delegate. Below are the
configuration steps we followed.

Creating the Team
1.) Login to User application as the Admin.
2.) In the Administration Tab, under RBPM Provisioning and Security,
selected Team Configuration.
3.) Created a new team with Domain as "Provisioning Domain", set the
Manager of the Request Approver and Delegate (Both report to the same
Manager) as the Manager of the Team.
4.) Selected Members as a Manager-Employee relationship and saved.
5.) In the Permissions Configuration, we selected the Workflow PRD in
focus as the Provisioning Request Definition, and selected Configure
Delegate as the Permission.
6.) Saved the Team configurations and the Team was created

Assigning the Delegate
1.) Login into User Application as the Manager of the two users (Also
the Manager of the Team created Above)
2.) Under Setting and Team Setting, selected "Team Delegate Assignment"
3.) Selected the Team created in the Above steps
4.) Selected Original Approver of the workflows as the User
5.) In the Team Delegate Assignment Page, set the "Delegate Assigned" as
the Delegate User, set the Expiration as "No Expiration", Selected the
Workflow in focus as the Workflow for which the Delegation should occur.
Submitted the page. Delegation for the Original Approver was
successfully created.

Enabling Delegation for the Original Approve
1.) Login to User Application as the Original Approver
2.) Under Setting, selected "Edit Availability"
3) In the Change Status field, selected "Not Available for Specific
4.) Left the "Unavailable From" as the default current Date Time,
Selected "No Expiration"
5.) Under "Request Type Selection", Selected the workflow in focus.
Clicked Add Button.
6.) Submit the request. Availability for the User was successfully set
to "Not Available or Specified Requests".

After all these steps we were expecting the workflow approval requests
to go the the Delegate instead of the Original Approver. But the
requests are still going to the Original Approver.

Please let me know if we have missed any steps here or if we are doing
anything wrong which is causing it to behave so.

Thank you


AD273041's Profile: https://forums.netiq.com/member.php?userid=5251
View this thread: https://forums.netiq.com/showthread.php?t=49439