Hi,

I have followed the docs on how to secure the Jboss server at
http://tinyurl.com/lfh5vr8

My problem is that when I start the jboss server it does read the
server.xml file but it does not use those ports. I know it reads it
since I had misspelled the keyfile and it complained about it.

The server listens and works on http port 8180 not 8080, in the file it
redirects 8080 to 8443 and if I try to access it on 8443 nothing
answers.
There has to be another configuration file I have missed but I cant find
any other references.

This is the beginning of my server.xml file:
<Server>

<!-- Optional listener which ensures correct init and shutdown of
APR,
and provides information if it is not installed -->
<Listener className="org.apache.catalina.core.AprLifecycleLi stener"
SSLEngine="on" />
<!--Initialize Jasper prior to webapps are loaded. Documentation at
/docs/jasper-howto.html -->
<Listener className="org.apache.catalina.core.JasperListener " />

<Service name="jboss.web">

<!-- A HTTP/1.1 Connector on port 8080 -->
<Connector protocol="HTTP/1.1" port="8080"
address="${jboss.bind.address}"
connectionTimeout="20000" redirectPort="8443" />

<!-- Add this option to the connector to avoid problems with
..NET clients that don't implement HTTP/1.1 correctly
restrictedUserAgents="^.*MS Web Services Client Protocol
1.1.4322.*$"
-->

<!-- A AJP 1.3 Connector on port 8009 -->
<Connector protocol="AJP/1.3" port="8009"
address="${jboss.bind.address}"
redirectPort="8443" />

SSL/TLS Connector configuration using the admin devl guide
keystore
<Connector protocol="HTTP/1.1" SSLEnabled="true"
emptySessionPath="true"
port="8443" address="${jboss.bind.address}"
scheme="https" secure="true" clientAuth="false"
keystoreFile="${jboss.server.home.dir}/conf/uakey.keystore"
keystorePass="changed" sslProtocol = "TLS" />


--
joakim_ganse
------------------------------------------------------------------------
joakim_ganse's Profile: https://forums.netiq.com/member.php?userid=159
View this thread: https://forums.netiq.com/showthread.php?t=50189