I have an issue with a Notes driver, where I am using multiple drivers.
I renamed the entitlements from the package names to avoid confusion.
Now, the User entitlement is not generating a valid value in the
resource object. This is a valueless entitlement, which usually means
the JSON string is empty, only having a "{}" in the param element in
nrfEntitlementRef. It should look like...


instead, I get


So, when assigning this resource, the Roles driver errors out with an
Invalid JSON String, and will not process the Resource into an
Entitlement. When I manually edit the attribute, it works. However,
something, somewhere, seems to be changing it back to the invalid

NetIQ decided it would be a good idea to hard code the entitlement names
into the initialization code. I exported both drivers, searched the XML
for the old names and found none. I went so far as to rename all the
GCV's as well with the new names. The EntitlementConfiguration says
these are IDM4 type entitlements, but no JSON strings. The Group
entitlements, which were also renamed, but are Valued entitlements,
appear to be working great. Attributes appear normal, and when
assigned, they actually put the user into the appropriate group in

Where does UA get the information to build the nrfEntitlementRef
attribute on the Resource object? Is it being treated as a legacy
entitlement for some reason? Does this have something to do with
renaming the Entitlement?

As an aside, because I know someone will ask, I did try to revert the
changes but that failed. I tried both in Outline View, and in the Driver
Properties/Packages view. Neither one did anything when I tried to
revert the Entitlements. The next "funny thing", only the User
entitlement has the black star on it, but I renamed both the User and
Group entitlements.

<insert twilight zone music here>

tse7147's Profile: https://forums.netiq.com/member.php?userid=466
View this thread: https://forums.netiq.com/showthread.php?t=51568