Hello guys! I have myself a little issue i can't get around. I'm working
on a few workflows for a client, one of them is a modification flow.

The client requested that when a value is modified in the form by the
requester said value's label should be flagged red to inform the
approver which fields were modified.

Detecting the modification was easy, just comparing the IDV's values to
the fields onload would get the job done.

Now comes the part where i need some help. Using this thread as a guide
I tried to change the color of a field's label to red using the jQuery
engine included with UA as an external script for the form
(/IDMProv/javascript/jQuery/scripts/jquery-1.4.2.min.js) and the
following function as an inline script:

function flagLabel(fieldName){
$(document).ready(function() {
$("#" + fieldName +"_lbl").css({"color":"#FF0000"});

Then in a test workflow i applied that function to a test field on the
onload event like this:

//Inside the onload

There was no change whatsoever. Just to make sure i wasn't mistyping
something i tried the exact function shown in the thread and changed the
field's name to "reason".

$(document).ready(function() {
$("#reason_lbl").css({ "color":"#8B008B", "font-style":"italic",
"font-size":"large", "font-weight":"bold" });

$("#_reason").css({ "color":"#FF0000", "border":"solid-style" });


After testing it i got a change on the label! But the change was on the
size (it got bigger) and inclination (it went italic) not on the color
(which should be some gradient of purple according to the description on
the thread). What did also change was the color of the field's font
(like when i typed into the field the text would be red).

To make things weirder after removing the onload event from the field i
set the style on the "Label cell style" property inside Designer to
"color: #FF0000" and there were no changes either.

What is the mistake I'm making? Am i missing a parameter on the .css
function? Do i need to set another property in Designer?

These tests were performed in a "text" field of type "string". The UA
version is 4.0.2.

Thanks in advance for any help you can provide

EPedros's Profile: https://forums.netiq.com/member.php?userid=5531
View this thread: https://forums.netiq.com/showthread.php?t=52277