Hi!

Im testing the userapp feature of the new Validator 1.2 following the
included userapp sample.

A simple test starts a workflow, waits (asserts) for the approval task
assignment, echos the process id and finally should approve the request.
All tests except the approval are working as expected. The approve test
fails with "No task for this process/user while executing action method
approveRequest".

When looking at the test result details, I do not understand the
"UserAppConnector: approveRequest() - PRD: null" ...


12/12/2013 16:05:20 INFO: ================================= TEST
=======================================
12/12/2013 16:05:20 INFO: Executing test: PRD Test
12/12/2013 16:05:20 INFO: -------------------------------- TEST ACTION
---------------------------------
12/12/2013 16:05:20 INFO: UserAppConnector: startWorkflow() - PRD:
cn=DUKPRD-Sample,cn=RequestDefs,cn=AppConfig,cn=User Application
Driver,cn=driverset1,o=system
12/12/2013 16:05:20 INFO: UserAppConnector: startWorkflow() - PRD
recipient: cn=itd-reibenwein,ou=sa,o=data
12/12/2013 16:05:20 INFO: UserAppConnector: startWorkflow() - RequestID:
93b7c02ff8364ec29357ba85f3608d76
12/12/2013 16:05:20 INFO: -------------------------------- TEST ACTION
---------------------------------
12/12/2013 16:05:20 INFO: UserAppConnector:
assertActivityCommentsContains() - PRD Process ID:
93b7c02ff8364ec29357ba85f3608d76
12/12/2013 16:05:20 INFO: UserAppConnector:
assertActivityCommentsContains() - PRD Activity Name: Activity1
12/12/2013 16:05:20 INFO: UserAppConnector:
assertActivityCommentsContains() - PRD Expected Comment: User task
assigned to reviewer UserApp Administrator
12/12/2013 16:05:20 INFO: UserAppConnector:
assertActivityCommentsContains() - PASSED
12/12/2013 16:05:20 INFO: -------------------------------- TEST ACTION
---------------------------------
12/12/2013 16:05:20 INFO: Echo: Request with ID
93b7c02ff8364ec29357ba85f3608d76 is waiting for approval.
12/12/2013 16:05:20 INFO: -------------------------------- TEST ACTION
---------------------------------
12/12/2013 16:05:20 INFO: UserAppConnector: approveRequest() - PRD:
null
12/12/2013 16:05:20 INFO: UserAppConnector: approveRequest() - PRD
recipient: cn=itd-reibenwein,ou=sa,o=data
12/12/2013 16:05:21 INFO: java.lang.AssertionError: java.lang.Exception:
No task for this process/user while executing action method
approveRequest
12/12/2013 16:05:21 INFO: *********** FAILING TEST PRD Test - CONTINUE
TO NEXT TEST ***********
12/12/2013 16:05:21 INFO: Test execution complete: PRD Test


My UserApp is version 4.0.2 PatchC running on SLES 11 SP1 and i can
approve the task manually. Also tried a Approve Request as Proxy, also
doesnt work.


Any ideas whats wrong here?

Greetings,
Thomas


--
reibenwein
------------------------------------------------------------------------
reibenwein's Profile: https://forums.netiq.com/member.php?userid=1382
View this thread: https://forums.netiq.com/showthread.php?t=49444