rtruscot wrote:

>
> Hi Edward,
>
> Extra info:
>
> AGW 3.2 Service running on SLES 11 SP2 AWS AMI
>
> agw3:~ # cat /etc/SuSE-release
> SUSE Linux Enterprise Server 11 (x86_64)
> VERSION = 11
> PATCHLEVEL = 2
>
> agw3:~ # rpm -qa | grep -i kernel
> kernel-firmware-20110923-0.7.64
> kernel-ec2-base-3.0.13-0.27.1
> kernel-ec2-3.0.13-0.27.1
>
> Yep I have started apache with debug but still nothing useful in the
> logs:
>
> [Wed Aug 08 02:36:51 2012] [debug] mod_amlogging.cpp(54):
> amlogging_post_config()- Start
> [Wed Aug 08 02:36:51 2012] [debug] mod_amlogging.cpp(63):
> amlogging_post_config()- Exit first time through
> [Wed Aug 08 02:36:51 2012] [info] Init: Seeding PRNG with 288 bytes of
> entropy
> [Wed Aug 08 02:36:51 2012] [info] Loading certificate & private key of
> SSL-aware server
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_pphrase.c(470):
> unencrypted RSA private key - pass phrase not required
> [Wed Aug 08 02:36:51 2012] [info] Init: Generating temporary RSA
> private keys (512/1024 bits)
> [Wed Aug 08 02:36:51 2012] [info] Init: Generating temporary DH
> parameters (512/1024 bits)
> [Wed Aug 08 02:36:51 2012] [info] Init: Initializing (virtual) servers
> for SSL
> [Wed Aug 08 02:36:51 2012] [info] Configuring server for SSL protocol
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(465): Creating
> new SSL context (protocols: SSLv2, SSLv3, TLSv1)
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(664): Configuring
> permitted SSL ciphers
> [SSLV3:TLSv1:!NULL:+HIGH:-EXPORT40:-EXPORT56:-MEDIUM:-LOW]
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(748): Configuring
> server certificate chain (1 CA certificate)
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(420): Configuring
> TLS extension handling
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(795): Configuring
> RSA server certificate
> [Wed Aug 08 02:36:51 2012] [debug] ssl_engine_init.c(834): Configuring
> RSA server private key
> [Wed Aug 08 02:36:51 2012] [info] mod_ssl/2.2.22 compiled against
> Server: Apache/2.2.22, Library: OpenSSL/0.9.8h
> [Wed Aug 08 02:36:51 2012] [debug] ../mod_agmon.c(246): agmon:
> post_config()- End, First time through
> [Wed Aug 08 02:36:51 2012] [debug] ../mod_disk_cache_monitor.c(279):
> disk_cache_monitor: post_config()- Start
> [Wed Aug 08 02:36:51 2012] [debug] ../mod_disk_cache_monitor.c(289):
> disk_cache_monitor: post_config()- End, First time through
> [Wed Aug 08 02:36:51 2012] [debug] ../mod_bgproc.c(119):
> bgproc_post_config()- Start
> [Wed Aug 08 02:36:51 2012] [debug] ../mod_bgproc.c(128):
> bgproc_post_config()- Exit first time through
>
> If I comment out:
>
> [I]Include /etc/opt/novell/ag/mod_novell_ag.confI]
>
> from the /etc/opt/novell/ag/mod_novell_ag.conf file then apache gets a
> little further and them bombs as you would expect. When I do this the
> general protection fault is not seen in /var/log/messages.
>
> Its as if the pid is being killed by the os somehow. Not sure if its
> bad code in mod_novell_ag.so or something else.
>
> I have also made sure that AppArmor is disabled.
>
> The default installed apache2 install seems to run fine (its not
> running when i try to start novell-apache2) so i dont think its a port
> binding issue. Maybe there is a conflict there with the pre installed
> binaries. Maybe ill try to uninstall the sles included apache and then
> reinstall the LAG.
>
> Might have to look at running the full appliance instead but its a
> pain to get pre built vm's into ec2.


I reckon it would be the best way to go to use the MAG appliance. What
you could try is to find out what install details are used to create
that VM and see if you can duplicate it (or I'm happy to try as well).
See if you can find a autoyast file and if there's one I'm happy to try
for you.

--
Cheers,
Edward