Dear all,

Based on the following 'article' (http://tinyurl.com/mrnt9zc), I
configured our NAM 3.2.2 IR2 environment with ServiceNow.

The Login works fine and I am auto-logged in without any issues.
However we have some issues with the logout.
ServiceNow displays the following error:
Code:
--------------------
Could not validate SAML LogoutResponse - Expected: urnasis:names:tc:SAML:2.0:status:Success, actual: urnasis:names:tc:SAML:2.0:status:Responder
--------------------


When I look into the log files, I find the following Logout Request:

Code:
--------------------

<saml2p:LogoutRequest xmlns:saml2p="urnasis:names:tc:SAML:2.0rotocol" ID="SNCf2a51d11b30bf0510a59010b18cdcb4a" IssueInstant="2014-01-31T11:17:29.776Z" Version="2.0">
<saml2:Issuer xmlns:saml2="urnasis:names:tc:SAML:2.0:assertion">https://myinstance.service-now.com</saml2:Issuer>
<saml2:NameID xmlns:saml2="urnasis:names:tc:SAML:2.0:assertion" Format="urnasis:names:tc:SAML:1.1:nameid-format:unspecified">username</saml2:NameID>
<saml2p:SessionIndex>idcKoNevzpy8iC5BcZU78Jngissb8 </saml2p:SessionIndex>
</saml2p:LogoutRequest>

--------------------


And the following Logout Response:

Code:
--------------------

<samlp:LogoutResponse xmlns:samlp="urnasis:names:tc:SAML:2.0rotocol" xmlns:saml="urnasis:names:tc:SAML:2.0:assertion" Destination="https:/myinstance.service-now.com/navpage.do" ID="id9MDqi0vTjNoqe0TOGRZXO45hDis" InResponseTo="SNCf2a51d11b30bf0510a59010b18cdcb4a" IssueInstant="2014-01-31T11:17:30Z" Version="2.0">
<saml:Issuer>https://namidtst.mycompany.com/nidp/saml2/metadata</saml:Issuer>
<samlp:Status>
<samlp:StatusCode Value="urnasis:names:tc:SAML:2.0:status:Responder"/>
</samlp:Status>
</samlp:LogoutResponse>

--------------------


But I do not see any error messages...

Do you know why I receive a "Responder" status code?

Thanks for your help!


--
marieno2
------------------------------------------------------------------------
marieno2's Profile: https://forums.netiq.com/member.php?userid=417
View this thread: https://forums.netiq.com/showthread.php?t=49868