Hi,

I am creating a new application of type SalesForce.

I have extracted the SalesForce URL from the WSDL as described in the
user's guide.
I also extracted the SalesForce SSL certificate and imported it into my
java keystore.

When I test the connection, I get this error message:
!openconnector.salesforce

When I try aggregating the application, I get this exception:

2013-06-25 11:52:30,917 WARN QuartzScheduler_Worker-3
sailpoint.api.Aggregator:988 - Exception during aggregation. Reason:
openconnector.Salesforce
sailpoint.tools.GeneralException: openconnector.Salesforce
at sailpoint.api.Aggregator.aggregateAccounts(Aggrega tor.java:1965)
at sailpoint.api.Aggregator.execute(Aggregator.java:1 226)
at
sailpoint.task.ResourceIdentityScan.execute(Resour ceIdentityScan.java:76)
at sailpoint.api.TaskManager.runSync(TaskManager.java :643)
at sailpoint.scheduler.JobAdapter.execute(JobAdapter. java:116)
at org.quartz.core.JobRunShell.run(JobRunShell.java:2 02)
at
org.quartz.simpl.SimpleThreadPool$WorkerThread.run (SimpleThreadPool.java:529)
Caused by: sailpoint.connector.ConnectorException:
openconnector.Salesforce
at
sailpoint.connector.OpenConnectorAdapter.createCon nector(OpenConnectorAdapter.java:191)
at
sailpoint.connector.OpenConnectorAdapter.iterateOb jects(OpenConnectorAdapter.java:658)
at
sailpoint.connector.ConnectorProxy.iterateObjects( ConnectorProxy.java:108)
at sailpoint.api.Aggregator.iterateObjects(Aggregator .java:2785)
at sailpoint.api.Aggregator.aggregateAccounts(Aggrega tor.java:1886)
... 6 more
Caused by: sailpoint.connector.ConnectorException:
openconnector.Salesforce
at
sailpoint.connector.OpenConnectorAdapter.instantia teConnector(OpenConnectorAdapter.java:153)
at
sailpoint.connector.OpenConnectorAdapter.createCon nector(OpenConnectorAdapter.java:183)
... 10 more
Caused by: java.lang.ClassNotFoundException: openconnector.Salesforce
at
org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoader.java:1680)
at
org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoader.java:1526)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at
sailpoint.connector.OpenConnectorAdapter.instantia teConnector(OpenConnectorAdapter.java:149)
... 11 more



I checked the ags.jar and indeed there is no Salesforce inside the
openconnector folder.
The other classes seem to be in place, there is a salesforce folder
under sailpoint/connector with its classes under
webservices/enterprise.

Has anyone encountered the same error while onboarding a SalesForce
application?

Thanks,

Charlie


--
cvattani
------------------------------------------------------------------------
cvattani's Profile: https://forums.netiq.com/member.php?userid=4974
View this thread: https://forums.netiq.com/showthread.php?t=48045