When running the UNIX_ExecUtil KS, it appears that standard output from
the Linux side is not being parsed by the KS.

For example, standard out for our Linux script is as follows. The
portion highlighted in red is mostly missing in the KS output. Even what
is there shows up at the end instead of in the middle (in green).



log_file= java.io.FileNotFoundException: *(No such file or
directory)
[log_file-> System.out]
Creating summariser <summary>
Created the tree successfully using
/home/sklong/monitor/jmx/FullPersonRequestProxy.jmx
Starting the test @ Tue Nov 04 11:11:56 EST 2014 (1415117516828)
Waiting for possible shutdown message on port 4445
-*1415117517683,174,FullPersonRequestProxy PROD
QueryRequest,200,OK,FullPersonRequestProxy PROD Basic Test
1-1,text,false,Test failed: text expected to contain
/<PublicId>P98*-90001</PublicId>/,2766,0
summary = * * *1 in * 0.2s = * *5.7/s Avg: * 174 Min: * 174 Max: * 174
Err: * * 1 (100.00%)
Tidying up ... * *@ Tue Nov 04 11:11:57 EST 2014 (1415117517916)
.... end of run


The KS shows this as standard output:


log_file= java.io.FileNotFoundException: (No such file or
directory)
[log_file-> System.out]
Creating summariser <summary>
Created the tree successfully using
/home/sklong/monitor/jmx/FullPersonRequestProxy.jmx
Starting the test @ Tue Nov 04 11:16:31 EST 2014 (1415117791782)
Waiting for possible shutdown message on port 4445
summary + 1 in 0.2s = 4.6/s Avg: 219 Min: 219 Max: 219
Err: 1

(100.00%) Active: 1 Started: 1 Finished: 0
summary = 1 in 0.2s = 4.6/s Avg: 219 Min: 219 Max: 219
Err: 1

(100.00%)
Tidying up ... @ Tue Nov 04 11:16:32 EST 2014 (1415117792989)
.... end of run
90001</PublicId>/,2766,0

Any idea why this is being stripped out? We have the KS looking for the
"Test failed", but it is not finding it.

Steve


--
stevelee
------------------------------------------------------------------------
stevelee's Profile: https://forums.netiq.com/member.php?userid=7211
View this thread: https://forums.netiq.com/showthread.php?t=52103