I have a new RHEL6 server that I installed eDir 8.8 SP7 on today. When I
used 'ndsconfig add' command to add this new server into an existing tree,
the process hung on the schema synchronization for an hour and a half. I
wound up killing the command with a CTRL+C. This stopped the command. I
checked the tree using C1 and I see that only two objects were created for
this server: the server object itself and the serverName PS object. No LDAP
server or LDAP group or KMO objects or anything else. This tells me it
didn't accomplish the full add. I even checked from one of the other
servers that pre-existed in the tree using ndsrepair -T command and there is
a communication error for this new server. When I tried the ndsrepair -T
command on this new server it stated "No eDirectory server instances
configured on this server."

I would like to successfully add this server to my tree, but I'm not sure
how to go about it now. Do I have to first remove the two objects it
created in the tree using C1? Should I try to use ndsconfig rm run from the
console of this new server? I have a feeling ndsconfig rm probably won't
work since it doesn't think there is a server instance configured. If using
C1 and deleting the two objects is the best option, is there anything I need
to check on this new server before attempting to re-add the new server to
the tree? Should I uninstall eDirectory on the new server and then
re-install it before trying to re-add it to the tree? I verified there are
no replicas on this new server.

I'm trying to figure out the best way to fix this partial add into the tree.
Any help is greatly appreciated.

Thanks,
Morgan