-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I typically just ignore it, but that's because I don't work with real
systems so maybe that's evil. Anyway, if that works for you (you know
that your packets won't be sent to the wrong box somehow) add the
- --insecure option to the curl command and it should be just fine. I
just tested with that one (I see you mentioned it as well) and it was
just fine to at least connect to the web service; I did not try
authentication at that point but you focused on the early connection so
I assume things will work once you get past this. If nothing else, get
more information from curl by using the '-v' option. Post the results here.

Good luck.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJQI9fKAAoJEF+XTK08PnB5jIwQAIcXzvJsh1 7Yo73zut3WzEvd
GlKmeKJktM07REJJIch3/PXfARGgC+33yLi4iS8kgUO/qeWicSllnjiUG008xBha
adBDtmcpURQar/WpnJ/B15cStg0GTavLtrObuJTtZY+32xJT3zNq2Af8AiC8Cb4D
Zyo1O+gTfRv87S3zJExYzoHoMnydAwkIR7GxLS4g+cdcmH1MdC 6Px8Q+9SFxdwpL
5xBG9oX3q3S8Ef3jfqgZPCFBbFad7HSBmZKVxsi+G0gEgi8oeI vMlbvIryDcHGPb
Zw5yvyD5V1+UcdQpCMso7JP1Vx6r5aUrDieGaQyzqrSpMVT6OH 6OCOSNu1n0ZXqy
imaOLeTQcgD791dodPFAhtuzM7qIt6eTj+5l2SA2yJOKx3FAAX kaXaJbdUbiX6gX
TmdO0lk86rZKnWthrDYPgRRkbT5ENWz34EQhr5/kEhdU6xF4H7rQBOoLl8Z27nTM
j5ftRmRKeipvayzqOvMLQwFMCmou4aMvZ5E0DgKJmbQUkiuQ3d xtAxnXHi3Ah19B
y0ibvAddbLEjuGfGKxa5yAmNqk+oNnS31/Im+l/AJtJ66VDHxDRfC91MN1LhyG3/
upatACd+qBwMY9M3xWhhyL88PYC8AwG6qKHSpOwR9FeDCV/RsB+dyJeWs7xkBCq6
5fHNQxpGVi6NkC6THpXu
=t26m
-----END PGP SIGNATURE-----