Home

Results 1 to 9 of 9

Thread: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice

Hybrid View

  1. #1
    sgeberl NNTP User

    Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    Hi,

    I tried to upgrade a Linux (SLES)-eDirectory-Installation from 8.8.6.5
    to 8.8.8 (downloaded SP8) and had serious Issues
    Installation: 2 Servers 1 Master and 1 Read-Write Replica (Test
    Installation)

    Upgrade of the Master worked out of the box, upgrade of the
    Read-Write-Replika failed with Removal of novell-NOVLice Error:
    (should be fixed with SP8 -> Bug 643038)????
    ================================================== ========

    %%% Backing up configuration files...
    %%% 32-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.
    %%% 64-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.

    %%% Removing old packages...

    %%% Removing novell-NOVLice...%%% Removal of novell-NOVLice was not
    successful.
    ================================================== ========

    I read that the Upgrade Skript searches for the package, does not find
    it and quit.

    - is this correct?
    - Is there any Workaround for this (editing skript, preinstall package
    etc.)?
    - Is there a way to list and manipulate the packages installed (via
    yum?, shell? - I'am from the apt, not the yum planet ;-))?

    thank you,
    Stephan


    --
    sgeberl
    ------------------------------------------------------------------------
    sgeberl's Profile: https://forums.netiq.com/member.php?userid=1401
    View this thread: https://forums.netiq.com/showthread.php?t=49344


  2. #2
    ab NNTP User

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice

    On 11/29/2013 08:44 AM, sgeberl wrote:
    >
    > Hi,
    >
    > I tried to upgrade a Linux (SLES)-eDirectory-Installation from 8.8.6.5
    > to 8.8.8 (downloaded SP8) and had serious Issues
    > Installation: 2 Servers 1 Master and 1 Read-Write Replica (Test
    > Installation)
    >
    > Upgrade of the Master worked out of the box, upgrade of the
    > Read-Write-Replika failed with Removal of novell-NOVLice Error:
    > (should be fixed with SP8 -> Bug 643038)????
    > ================================================== ========
    >
    > %%% Backing up configuration files...
    > %%% 32-bit NICI version(2.7.7) is already present. The version of NICI
    > available with this distribution (2.7.7) will not be installed.
    > %%% 64-bit NICI version(2.7.7) is already present. The version of NICI
    > available with this distribution (2.7.7) will not be installed.
    >
    > %%% Removing old packages...
    >
    > %%% Removing novell-NOVLice...%%% Removal of novell-NOVLice was not
    > successful.
    > ================================================== ========
    >
    > I read that the Upgrade Skript searches for the package, does not find
    > it and quit.
    >
    > - is this correct?
    > - Is there any Workaround for this (editing skript, preinstall package
    > etc.)?
    > - Is there a way to list and manipulate the packages installed (via
    > yum?, shell? - I'am from the apt, not the yum planet ;-))?


    'yum' is a tool for RHEL/CentOS, not SLES, so trying that is going to be
    about useful as trying apt-* on non-Debian platforms. What you want is
    'zypper' which is very similar in how it works for clients, and generally
    really awesome.

    It looks like this should be fixed already as the bug is old and was fixed
    back in 2010. With that said and your failure above, you can probably get
    past it by just installing that RPM manually from the installation media.
    The RPM file should be named similar to what you see above,
    novell-NOVLice-blahblah.rpm or something similar. If you do this and then
    try the installation gain hopefully it will see that the package is there
    and move on, though it should already prompt you to do that and still move
    on. Another option is to use the 'force' option of the installer, which I
    would not generally recommend doing since the upgrade should not require
    something to "force" it.

    Out of curiosity, was your previous installation of eDirectory an x86_32
    install or an x86_64 install? The way to check is to run the following
    command, since there is no way to guarantee that an x86_64 install of SLES
    has an x86_64 install of eDirectory until eDirectory 8.8 SP8 when the
    x86_32 installs were ended:

    Code:
    --------------------
    file /opt/novell/eDirectory/sbin/ndsd
    --------------------

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    sgeberl NNTP User

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    Thanks for the answer, I tried to install the module and got the message
    that it is already installed. Finaly I switched off the ndsd
    (/etc/init.d/ndsd stop) and the upgrade script worked. In the meantime I
    upgraded 5 additional servers and this issue did not apear, everything
    worked fine.

    thank you all,
    Stephan


    --
    sgeberl
    ------------------------------------------------------------------------
    sgeberl's Profile: https://forums.netiq.com/member.php?userid=1401
    View this thread: https://forums.netiq.com/showthread.php?t=49344


  4. #4
    Join Date
    Jul 2015
    Posts
    7

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    sgeberl;237657 Wrote:
    > Thanks for the answer, I tried to install the module and got the message
    > that it is already installed. Finaly I switched off the ndsd
    > (/etc/init.d/ndsd stop) and the upgrade script worked. In the meantime I
    > upgraded 5 additional servers and this issue did not apear, everything
    > worked fine.
    >
    > thank you all,
    > Stephan


    Hello

    I also tried to upgrade a Linux(SLES 11 SP3)-eDirectory-Installation
    from 8.8 SP6 v20601.18 to 8.8 SP8 and had the same issue:

    %%% Backing up configuration files...
    %%% 32-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.
    %%% 64-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.

    %%% Removing old packages...

    %%% Removing novell-NOVLice...%%% Removal of novell-NOVLice was not
    successful.

    And then exit the installation.

    I tried to stop the eDirectory and execute nds-install but the problem
    remains.

    Any idea how to solve this problem?

    Regards, Carlos.


    --
    cagrelo
    ------------------------------------------------------------------------
    cagrelo's Profile: https://forums.netiq.com/member.php?userid=8189
    View this thread: https://forums.netiq.com/showthread.php?t=49344


  5. #5

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice

    If you are just now upgrading (this thread is over 1.5 years old) be sure
    you are using the 8.8 SP8 Patch 5 installer; as a full installer, I
    believe you should be fine using it to upgrade from previous versions/SPs
    of eDirectory.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  6. #6
    Join Date
    Jul 2015
    Posts
    7

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    ab;259284 Wrote:
    > If you are just now upgrading (this thread is over 1.5 years old) be
    > sure
    > you are using the 8.8 SP8 Patch 5 installer; as a full installer, I
    > believe you should be fine using it to upgrade from previous
    > versions/SPs
    > of eDirectory.
    >
    > --
    > Good luck.
    >
    > If you find this post helpful and are logged into the web interface,
    > show your appreciation and click on the star below...



    Hello and thanks for the answer.

    First i used the 8.8 SP8 installer then i tried with the 8.8 SP8 Patch 5
    insaller and remains the same problem:

    ================================================== =================================

    %%% Upgrading NetIQ eDirectory from "8.8.6" to "8.8.8.5"...


    %%% One or more instances of root user are not running.Do you want to
    start those instances for pre upgrade healthcheck? '[y/n/q] ? 'y
    %%% Starting instance : :...cat: :: No such file or directory
    cat: :: No such file or directory
    cat: :: No such file or directory
    Another copy of ndsd running. Please remove
    /var/opt/novell/eDirectory/data/ndsd.pid and restart ndsd if this is not
    the case. done


    %%% Backing up configuration files...
    %%% 32-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.
    %%% 64-bit NICI version(2.7.7) is already present. The version of NICI
    available with this distribution (2.7.7) will not be installed.

    %%% Removing old packages...

    %%% Removing novell-NOVLice...%%% Removal of novell-NOVLice was not
    successful.

    ================================================== =================================

    In the /var/opt/novell/eDirectory/data/ndsd.pid i only see 1 instance
    and i also try restart the eDirectory but nothing happens.

    Regards, Carlos.


    --
    cagrelo
    ------------------------------------------------------------------------
    cagrelo's Profile: https://forums.netiq.com/member.php?userid=8189
    View this thread: https://forums.netiq.com/showthread.php?t=49344


  7. #7

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice

    Look in the /etc/opt/novell/eDirectory/conf/.edir/ directory for a file
    probably named 'instances.0' and see if you see your instance's nds.conf
    file in there. You should usually only have one, and it MUST be on the
    first line (bug in eDir stuff).

    If that is not the issue, look the nds.conf file listed in your
    instances.0 file and see if any lines are duplicated. Some may be very
    similar, but no lines should be duplicated. If they are, backup the
    current file for fun and then remove duplicate lines. I would not be
    surprised if this was your issue as it has caused problems in the past.

    Finally, if nothing else works, call the nds-install script as shown below
    and post all of the output somewhere (here if possible, but maybe Pastebin
    or similar sites due to post-size limits here) and share the link here for
    review.

    Code:
    bash -xv ./nds-install
    This will show how the script is running including variables, commands,
    etc., which basically lets you step through things until the problem is found.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  8. #8
    Join Date
    Jul 2015
    Posts
    7

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    ab;259333 Wrote:
    > Look in the /etc/opt/novell/eDirectory/conf/.edir/ directory for a file
    > probably named 'instances.0' and see if you see your instance's
    > nds.conf
    > file in there. You should usually only have one, and it MUST be on the
    > first line (bug in eDir stuff).
    >
    > If that is not the issue, look the nds.conf file listed in your
    > instances.0 file and see if any lines are duplicated. Some may be very
    > similar, but no lines should be duplicated. If they are, backup the
    > current file for fun and then remove duplicate lines. I would not be
    > surprised if this was your issue as it has caused problems in the past.
    >
    > Finally, if nothing else works, call the nds-install script as shown
    > below
    > and post all of the output somewhere (here if possible, but maybe
    > Pastebin
    > or similar sites due to post-size limits here) and share the link here
    > for
    > review.
    >
    > >

    Code:
    --------------------
    > >

    > bash -xv ./nds-install
    >

    --------------------
    > >

    >
    > This will show how the script is running including variables,
    > commands,
    > etc., which basically lets you step through things until the problem
    > is found.
    >
    > --
    > Good luck.
    >
    > If you find this post helpful and are logged into the web interface,
    > show your appreciation and click on the star below...


    In the nds.conf file, lines were triplicated!

    I remove those lines and the upgrade works perfect.

    Thanks ab

    Regards, Carlos.


    --
    cagrelo
    ------------------------------------------------------------------------
    cagrelo's Profile: https://forums.netiq.com/member.php?userid=8189
    View this thread: https://forums.netiq.com/showthread.php?t=49344


  9. #9
    Join Date
    Jul 2015
    Posts
    7

    Re: Upgrading eDirectory 8.8.6.5 -> 8.8.8 Err rm novell-NOVLice


    cagrelo;259332 Wrote:
    > Hello and thanks for the answer.
    >
    > First i used the 8.8 SP8 installer then i tried with the 8.8 SP8 Patch 5
    > insaller and remains the same problem:
    >
    > ================================================== =================================
    >
    > %%% Upgrading NetIQ eDirectory from "8.8.6" to "8.8.8.5"...
    >
    >
    > %%% One or more instances of root user are not running.Do you want to
    > start those instances for pre upgrade healthcheck? '[y/n/q] ? 'y
    > %%% Starting instance : :...cat: :: No such file or directory
    > cat: :: No such file or directory
    > cat: :: No such file or directory
    > Another copy of ndsd running. Please remove
    > /var/opt/novell/eDirectory/data/ndsd.pid and restart ndsd if this is not
    > the case. done
    >
    >
    > %%% Backing up configuration files...
    > %%% 32-bit NICI version(2.7.7) is already present. The version of NICI
    > available with this distribution (2.7.7) will not be installed.
    > %%% 64-bit NICI version(2.7.7) is already present. The version of NICI
    > available with this distribution (2.7.7) will not be installed.
    >
    > %%% Removing old packages...
    >
    > %%% Removing novell-NOVLice...%%% Removal of novell-NOVLice was not
    > successful.
    >
    > ================================================== =================================
    >
    > In the /var/opt/novell/eDirectory/data/ndsd.pid i only see 1 instance
    > and i also try restart the eDirectory but nothing happens.
    >
    > Regards, Carlos.


    Append more information about the problem:

    Server_Name:/ # ndsmanage
    Server instances management utility for Novell eDirectory 8.8 SP6
    v20601.19

    The following are the instances configured by root

    [1] /etc/opt/novell/eDirectory/conf/nds.conf : .Server_Name Server_Name
    Server_Name.SERVICES.COMPANY_NAME SERVICES.COMPANY_NAME
    SERVICES.COMPANY_NAME.METADIRECTORY METADIRECTORY METADIRECTORY. :
    x.x.x.x@524
    x.x.x.x@524
    x.x.x.x@524
    x.x.x.x@524 : INACTIVE

    Regards


    --
    cagrelo
    ------------------------------------------------------------------------
    cagrelo's Profile: https://forums.netiq.com/member.php?userid=8189
    View this thread: https://forums.netiq.com/showthread.php?t=49344


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •