Hi All

I am trying to configure SNMP for Edirectory

Following the doco in https://www.netiq.com/documentation/...a/ag7i1ei.html

Server SLES 11.3 OES 11.2 fully patched

I'm getting the following errors when I start the ndssnmpsa service

Jul 13 12:27:55 pegasus-sydney-cl1 Information: Logged in successfully to 'LOCALHOST' eDirectory server.
Jul 13 12:27:55 pegasus-sydney-cl1 Error: subagt(trapcomp): socket call failed, 97
Jul 13 12:29:55 pegasus-sydney-cl1 Error: subagt(trapcomp/SubagtPortUpdate): NCP Extn call failed: iRet: -625 ReplySize: 556
Jul 13 12:29:55 pegasus-sydney-cl1 Error: eDirectory SNMP trap component : SNMP server module of LOCALHOST:524 eDirectory server is down. Error code : -625
Jul 13 12:29:55 pegasus-sydney-cl1 Error: subagt: Can not monitor DS - LOCALHOST:524
Jul 13 12:29:55 pegasus-sydney-cl1 Error: subagt(trapcomp): ServerName - LOCALHOST:524 - Alloccation Failed
Jul 13 12:29:55 pegasus-sydney-cl1 Error: eDirectory SNMP initialization component. Error code : -625
Jul 13 12:29:55 pegasus-sydney-cl1 Error: subagt(trapcomp): Exiting from TrapThread

Im using admin to login and as the first line states it authenticates to eDirecttory successfully


the end of my snmp.conf is

trapsink 10.242.1.14 public
# rwcommunity mysecret 127.0.0.1

master agentx

#eDiretcory
com2sec demouser default public
group demogroup v1 demouser
view all included .1
access demogroup "" any noauth exact all all all


I configured another server and its doing exactly the same thing

What have I got wrong ??

Thanks in advance

Mark