Hi,
Thanks, was looking for such a solution. Amazed Novell don't normally
make Set Password available for Task For Modify. For anybody who wants
to try this, couple of gotchas:
First line of the file should read:
<%@ page pageEncoding="utf-8" contentType="text/html;charset=utf-8"
import="com.novell.webaccess.common.JSPConduit,
com.novell.emframe.dev.eMFrameUtils"%>
These following lines should be added near the top of the file, if they
don't exist
<%
JSPConduit c = JSPConduit.getJSPConduit(request);
c.stringTable("FwResources");
c.stringTable("DevResources");
%>
Also, if you change the task at all in Plug-in Studio, you will need to
add these changes into the new jsp file created as they will be lost.

Thanks
Mark
fbarbier1;189088 Wrote:
> Thank you all for your help.
>
> Here is my solution.
>
> on the link 'Cool Solutions: Creating a Custom Help Desk Page for
> iManager' (http://www.novell.com/coolsolutions/tip/18777.html) they say
> that after the tag </TABLE> we have to insert the parts.
> But if you look inside the jsp file pShared_PasswordRestrictions.jsp
> there is 2 setPassword functions.
> The one on the previous link is in fact commented on the code and not
> working.
> You need to use the other setPassword function from the
> pShared_PasswordRestrictions.jsp file.
>
> Wolfgang Schreiber;2125643 Wrote:
> > I think, the password field in the Plugin Studio is only available

> for
> > the
> > "Create" target
> >
> > To put a "Set Password" action on another page, locate the JSP that
> > the
> > plugin studio creates, then proceed as outlined in
> > 'Cool Solutions: Creating a Custom Help Desk Page for iManager'
> > (http://www.novell.com/coolsolutions/tip/18777.html)
> >
> >
> > Wolfgang
> >
> >
> > "fbarbier1" wrote in message
> > news:fbarbier1.4xwk1c@no-mx.forums.novell.com...
> >
> >
> > I am using iManager 2.7.4 and I have to do a new filter for a Help
> > desk.
> > I want to have access to the password. I can't find the Set Password.
> >
> > Does anyone have an idea ?
> >
> > Thanks
> >
> >
> > kjhurni;1882917 Wrote:
> > > I'm not sure if it matters, but this is what I did:
> > >
> > > Login as Admin into iMangler
> > > Configuration -> RBS Configuration -> PlugIn Studio
> > > New
> > >
> > > In Step 1, I did:
> > > Available Classes: User
> > > Target Device: Default
> > > Plugin Type: Task for Create
> > > Left Aux classes unchecked
> > >
> > > It defaulted to show me:
> > > CN
> > > Surname
> > > Container
> > >
> > > (I think that was it)
> > >
> > > I added
> > > Given Name
> > > Description
> > > and then I found the Set Password at the top right-hand side
> > >
> > > I'm using iMangler 2.7.3 on OES2 SP1 Linux with eDir 8.8.5 FTF1 and
> > > NMAS whatever. We have Universal Password enabled.

> >
> >
> > --
> > fbarbier1
> >

> ------------------------------------------------------------------------
> > fbarbier1's Profile: 'View Profile: fbarbier1 - Novell - NetIQ -

> SUSE'
> > (http://forums.novell.com/member.php?userid=114695)
> > View this thread: 'Plug-In Studio - password attribute?'
> > (http://forums.novell.com/showthread.php?t=391271)

>
>
> --
> fbarbier1
> ------------------------------------------------------------------------
> fbarbier1's Profile: http://forums.novell.com/member.php?userid=114695
> View this thread: http://forums.novell.com/showthread.php?t=391271



--
mratcliffe
------------------------------------------------------------------------
mratcliffe's Profile: https://forums.netiq.com/member.php?userid=3754
View this thread: https://forums.netiq.com/showthread.php?t=38758