Hello, I just installed the Dashboard and some NOC portlets are not
working: Alarms, Summary, Chart Builder and Layout. The rest of NOC
applications (Performance, Property Table, Tree Map) are working well.

Alarms and Summary applications shows the legend "Alarms is temporarily
unavailable." in a red label.

Chart Builder displays only this: "ERROR: Couldn't Load Appearance
File:".

Layout, shows this:


Unable to emit drawing.

java.lang.NullPointerException
at javax.swing.MultiUIDefaults.getUIError(MultiUIDefa ults.java:133)
at javax.swing.UIDefaults.getUI(UIDefaults.java:742)
at javax.swing.UIManager.getUI(UIManager.java:989)
at javax.swing.JPanel.updateUI(JPanel.java:109)
at javax.swing.JPanel.(JPanel.java:69)
at javax.swing.JPanel.(JPanel.java:92)
at javax.swing.JPanel.(JPanel.java:100)
at com.mosol.Formula.Client.ui.ViewPanel.(ViewPanel.j ava:41)
at
com.mosol.Formula.Client.ui.bsv.view.LayoutPanelUI .(LayoutPanelUI.java:1214)
at
com.mosol.Formula.Client.ui.bsv.view.LayoutPanel.( LayoutPanel.java:88)
at
com.mosol.Formula.Server.LayoutConverter.emitDrawi ng(LayoutConverter.java:454)
at
com.mosol.Formula.Server.SVGServlet.sessionGet(SVG Servlet.java:1787)
at
com.mosol.Formula.Server.RemoteLayoutServlet.doGet (RemoteLayoutServlet.java:46)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:717)
at
org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:290)
at
org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:206)
at
org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:233)
at
org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:191)
at
org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
at
com.mosol.Formula.Server.WebServerErrorReportValve .invoke(WebServerErrorReportValve.java:69)
at
org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:109)
at
org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:298)
at
org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:852)
at
org.apache.coyote.http11.Http11Protocol$Http11Conn ectionHandler.process(Http11Protocol.java:588)
at
org.apache.tomcat.util.net.JIoEndpoint$Worker.run( JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:662)

Don't know if each of them is a isolated issue or have common failure.

Thanks for any clue to fix this behaviour.


--
dsalasr
------------------------------------------------------------------------
dsalasr's Profile: https://forums.netiq.com/member.php?userid=771
View this thread: https://forums.netiq.com/showthread.php?t=47706