We are running IDM and RBPM 4.0.2 Advance edition with the approved
JBOSS version and MySQL all on RedHat Linux 64bit version 5.10. We are
only using UserApp for password self service functions and eDirectory
user account lookups.

I had an issue yesterday morning where the UserApp site was up and
running, and after clicking on the log in button and entering valid
credentials, the browser busy icon would just spin and spin. I looked at
the "/opt/novell/idm/jboss/server/IDM/log/server.log" file and there
wasn't what I would call an error per say. I was in a rush to get the
site back up and so I couldn't get much information from the logs except
a screenshot of the last few lines that were showing in the server.log
file right before I stopped and started userapp. My max thread count of
300 had not been met and the jboss admin console didn't show a sign of
any problems. Below are the last 2 lines I captured real quick and 6
minutes prior there was a successful password reset.

2014-03-26 01:43:34,345 INFO [STDOUT] (Thread-20466) <<open session> >>
reply (NMAS ID) 241172608
2014-03-26 01:43:46,101 INFO [STDOUT] (Thread-20472) <<open session> >>
reply (NMAS ID) 241172612

One thing that was interesting to me is, before I restarted userapp, I
tried logging into the site....it obviously didn't work and so I ran my
stop and start script for userapp, and after the site came back up I
refreshed my browser and went right back to the site and I was sent to
the password page without being prompted for credentials and logging in
and I saw in the server.log where it showed me logging in successfully;
so the credentials I entered before the restart of the app were stored
somewhere and I wasn't prompted to enter credentials after the restart.
Not sure how that might be helpful in figuring out what happened but the
more information I can provide the better.

Any ideas on why my userapp stopped letting users log in.

Thank you,

wferguson's Profile: https://forums.netiq.com/member.php?userid=360
View this thread: https://forums.netiq.com/showthread.php?t=50373