Home

Results 1 to 8 of 8

Thread: hide user's responses

  1. #1
    tammai NNTP User

    hide user's responses


    Hi,
    I would like to be able to hide the challenge responses on the screen,
    is there an option in SSPR to hide the user's responses.
    I noticed that when I type the answers to the challenges, the answers
    are displayed.
    Much appreciated.


    --
    tammai
    ------------------------------------------------------------------------
    tammai's Profile: https://forums.netiq.com/member.php?userid=7082
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  2. #2
    kjhurni NNTP User

    Re: hide user's responses


    tammai;243179 Wrote:
    > Hi,
    > I would like to be able to hide the challenge responses on the screen,
    > is there an option in SSPR to hide the user's responses.
    > I noticed that when I type the answers to the challenges, the answers
    > are displayed.
    > Much appreciated.


    In the 3.0.0.2 default installation (without changing anything) it hides
    the responses (all you see are "*" instead of the characters). There's
    a button (again, default install) to allow the users to click the "show
    responses". Are you sure that they're not clicking that?

    I cannot, however, find the setting in the docs that mentions the "show
    responses" for that page/module/section.

    The only one I can find is for the passwords (show/hide passwords).

    --Kevin


    --
    kjhurni
    ------------------------------------------------------------------------
    kjhurni's Profile: https://forums.netiq.com/member.php?userid=322
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  3. #3
    tammai NNTP User

    Re: hide user's responses


    Hi Kevin,

    The challenge responses are hidden for me in the forgot password
    module.
    But in setup responses, it's type is text.
    I had a look at the jsp and the differences are
    input type="text" (fragment/setupresponses-form.jsp)
    vs
    input type="password" (forgottenpassword-responses.jsp)
    I did try out and changed fragment/setupresponses-form.jsp input
    type="password" and the responses became "*'s"
    I am probably doing it wrong.


    --
    tammai
    ------------------------------------------------------------------------
    tammai's Profile: https://forums.netiq.com/member.php?userid=7082
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  4. #4
    kjhurni NNTP User

    Re: hide user's responses


    tammai;243234 Wrote:
    > Hi Kevin,
    >
    > The challenge responses are hidden for me in the forgot password
    > module.
    > But in setup responses, it's type is text.
    > I had a look at the jsp and the differences are
    > input type="text" (fragment/setupresponses-form.jsp)
    > vs
    > input type="password" (forgottenpassword-responses.jsp)
    > I did try out and changed fragment/setupresponses-form.jsp input
    > type="password" and the responses became "*'s"
    > I am probably doing it wrong.


    Strange, when I login as any of our users (test accounts, etc.) and go
    to the Setup Password Responses page to change my answers, it defaults
    to hide the responses.
    You're saying that your system defaults to SHOW what you type?

    I'm on 3.0.0.2 and have tested 3 separate installs and they all behave
    the same in FF ESR 24.2.0 and IE 10.
    What codebase are you on?

    --Kevin


    --
    kjhurni
    ------------------------------------------------------------------------
    kjhurni's Profile: https://forums.netiq.com/member.php?userid=322
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  5. #5
    tammai NNTP User

    Re: hide user's responses


    I downloaded this recently, hope it is the latest version code.
    Thu Apr 10 16:38:51 EST 2014, INFO , password.pwm.PwmApplication, SSPR
    v3.0.0.2 b1233 (Release) open for bidness! (616ms)


    --
    tammai
    ------------------------------------------------------------------------
    tammai's Profile: https://forums.netiq.com/member.php?userid=7082
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  6. #6
    kjhurni NNTP User

    Re: hide user's responses


    tammai;243263 Wrote:
    > I downloaded this recently, hope it is the latest version code.
    > Thu Apr 10 16:38:51 EST 2014, INFO , password.pwm.PwmApplication, SSPR
    > v3.0.0.2 b1233 (Release) open for bidness! (616ms)


    Yeah, 3.0.0.2 is the latest (well that I see when I download patches)

    I wonder why your setup is different than mine, only because I cannot
    find the setting in the configuration that controls the Setup Response
    section. I see an option for the PASSWORD change to hide/show
    responses, but not for the Challenge/Response setup.

    Maybe Jason will wander by and see this.

    Otherwise I'm at a loss, unfortunately.

    --Kevin


    --
    kjhurni
    ------------------------------------------------------------------------
    kjhurni's Profile: https://forums.netiq.com/member.php?userid=322
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  7. #7
    jrivard NNTP User

    Re: hide user's responses


    Actually, SSPR 3.1 is the latest version.

    For both 3.0 and 3.1 however, the setup responses page is initially
    masked (with field type of password), and then if show/hide password
    option is enabled there is a button to make the fields visible (or in
    3.1 there is an eye icon near each field). If your seeing different
    behavior than this there is either something wrong with your deployment
    (try deleting the contents of tomcat/work/* and clearing your browser
    cache), a browser bug (try with a different browser), or your
    configuration (try with a from-scratch configuration and if that is
    working properly, add back your customization until you find what is
    breaking it).

    kjhurni;243285 Wrote:
    > Yeah, 3.0.0.2 is the latest (well that I see when I download patches)
    >
    > I wonder why your setup is different than mine, only because I cannot
    > find the setting in the configuration that controls the Setup Response
    > section. I see an option for the PASSWORD change to hide/show
    > responses, but not for the Challenge/Response setup.
    >
    > Maybe Jason will wander by and see this.
    >
    > Otherwise I'm at a loss, unfortunately.
    >
    > --Kevin



    --
    jrivard
    ------------------------------------------------------------------------
    jrivard's Profile: https://forums.netiq.com/member.php?userid=541
    View this thread: https://forums.netiq.com/showthread.php?t=50497


  8. #8
    kjhurni NNTP User

    Re: hide user's responses


    jrivard;243358 Wrote:
    > Actually, SSPR 3.1 is the latest version.
    >
    > For both 3.0 and 3.1 however, the setup responses page is initially
    > masked (with field type of password), and then if show/hide password
    > option is enabled there is a button to make the fields visible (or in
    > 3.1 there is an eye icon near each field). If your seeing different
    > behavior than this there is either something wrong with your deployment
    > (try deleting the contents of tomcat/work/* and clearing your browser
    > cache), a browser bug (try with a different browser), or your
    > configuration (try with a from-scratch configuration and if that is
    > working properly, add back your customization until you find what is
    > breaking it).


    Thanks Jason. I see 3.1 is out (I'd had an SR open and they had me
    using beta code, though apparently a few days later 3.1 was released).
    The issue--I'm seeing it on all 3 of my servers (one is 3.1, the other
    two are 3.0.0.2) is this;

    There is no option button to hide/show the RESPONSES. Passwords, yes,
    but that's different, and it's in a completely different section of the
    UI (password, not responses)

    In ALL 3 of my setups, there is no option in the Admin section to
    control whether the user has a show/hide button for RESPONSES.

    We've got the show/hide enabled for passwords for all 3 servers.

    (yes, tomcat/work was deleted in order to do the upgrades).

    Are you saying that in 3.1 instead of a button there's an "eye" icon and
    that in 3.0.0.2 we should see a button option?

    Although in my setups (differing from the OP), the responses are ALWAYS
    NOT masked with no way obvious way to mask them.

    --Kevin


    --
    kjhurni
    ------------------------------------------------------------------------
    kjhurni's Profile: https://forums.netiq.com/member.php?userid=322
    View this thread: https://forums.netiq.com/showthread.php?t=50497


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •