Home

Results 1 to 6 of 6

Thread: collector debug error: "SyntaxError: Invalid quantifier ?"

Hybrid View

  1. #1
    steve zeng NNTP User

    collector debug error: "SyntaxError: Invalid quantifier ?"


    Dear all,

    When i debug any collectors developed by NetIQ, system always popup
    error message: "SyntaxError: Invalid quantifier ?" , why? I can`t debug
    any collector!


    Thanks!
    Steve zeng


    --
    steve_zeng
    ------------------------------------------------------------------------
    steve_zeng's Profile: https://forums.netiq.com/member.php?userid=3875
    View this thread: https://forums.netiq.com/showthread.php?t=48077


  2. #2
    ab NNTP User

    Re: collector debug error: "SyntaxError: Invalid quantifier ?"

    Could you share an example? I load NetIQ collectors in the debugger
    regularly and have never seen that out of the box. Which version of
    Sentinel? Which collector plugin? What settings are set in the
    collector? Any filters configured?

    Good luck.

  3. #3
    steve zeng NNTP User

    Re: collector debug error: "SyntaxError: Invalid quantifier ?"


    Hi ab,
    My sentinel version is 7.0.3 and 7.1, they can not been debug, I
    load NetIQ Universal collector in the debugger and I always have seen
    error messages, I don`t configure any filters, I don`t know how to
    troubleshooting the problem, thanks!

    BR
    Steve zeng


    +----------------------------------------------------------------------+
    |Filename: exconfig.rar |
    |Download: https://forums.netiq.com/attachment.php?attachmentid=69 |
    +----------------------------------------------------------------------+

    --
    steve_zeng
    ------------------------------------------------------------------------
    steve_zeng's Profile: https://forums.netiq.com/member.php?userid=3875
    View this thread: https://forums.netiq.com/showthread.php?t=48077


  4. #4
    steve zeng NNTP User

    Re: collector debug error: "SyntaxError: Invalid quantifier ?"


    Hi ,

    I really need your help, I am delivering a sentinel project in
    customer, I am not a collector developer, but in fact, I still need to
    develop collector,In china, one people same as me need do many work, my
    position is Sentinel NTS, but I still need to do presale and need to
    delivery project, I still do IDM and Platesbin presale, although I have
    SSIM/Splunk/Arcsight experience, But I am not farmiliar with javascript,
    So I still study the programing, Perhaps I ask some detail problem, but
    I really ask to obtain your understand.
    I can not debug any collector in new installing sentinel 7.1 and
    7.0, I had send to you control.center.0.0.log,

    thanks again!


    --
    steve_zeng
    ------------------------------------------------------------------------
    steve_zeng's Profile: https://forums.netiq.com/member.php?userid=3875
    View this thread: https://forums.netiq.com/showthread.php?t=48077


  5. #5
    DCorlette NNTP User

    Re: collector debug error: "SyntaxError: Invalid quantifier ?"


    I believe we already answered this question over e-mail, but the problem
    you're running into indicates that you have a problem with a regular
    expression.

    Chosen at random from a Google search on the error message:
    http://tinyurl.com/meyntcb

    Since all of our Collectors are thoroughly tested before we ship them, I
    have to imagine the source of this error is a regular expression that
    you have written somewhere. Make sure the Collector is in the normal
    (not 'custom') execution mode before you try to debug, and try again.

    Incidentally, I believe this is a load-time error for JavaScript not a
    runtime error, so most likely you can't even get your code to load up in
    the debugger. This can be extremely frustrating because then it can be
    very hard to pinpoint the source of the error. Do you see a line number
    or something associated with the error?


    --
    DCorlette
    ------------------------------------------------------------------------
    DCorlette's Profile: https://forums.netiq.com/member.php?userid=323
    View this thread: https://forums.netiq.com/showthread.php?t=48077


  6. #6
    steve zeng NNTP User

    Re: collector debug error: "SyntaxError: Invalid quantifier ?"


    Dear all,

    I had got a resolve solution for debug collector error from
    (https://forums.netiq.com/showthread....ebugging-error) as
    following:


    There is a file: .\plugin-sdk\current\sdk\2011.1\common\utils.js in
    collector development dir,

    find


    Code:
    // Fixup of Finnish chars
    outStr = outStr.replace(/ä/g, "");
    outStr = outStr.replace(/ö/g, "");
    outStr = outStr.replace(/å/g, "");
    outStr = outStr.replace(/Ä/g, "");
    outStr = outStr.replace(/Ö/g, "");
    outStr = outStr.replace(/Å/g, "");
    return outStr;
    and change it to:


    Code:
    // Fixup of Finnish chars
    //outStr = outStr.replace(/ä/g, "");
    //outStr = outStr.replace(/ö/g, "");
    //outStr = outStr.replace(/å/g, "");
    //outStr = outStr.replace(/Ä/g, "");
    //outStr = outStr.replace(/Ö/g, "");
    //outStr = outStr.replace(/Å/g, "");
    outStr = " ";
    return outStr;
    And rebuild collector which will attach new corrected utils.js. Now
    debbuging should be possible.


    It's related to new 2011.1 SDK. It doesn't happend in 6.1.
    I think that it is connected with different regional settings of
    Windows. The problem is connected with Finish Unicode Characters. I
    suppose that my PC uses Chinese coding set of Unicode, Collector
    developer have Central Eastern Europe (CEE). And the trick is that in
    lines,
    outStr = outStr.replace(/ä/g, "");
    these strange characters /ä/g with CEE settings are changed into
    /?�/g, in regular expression /? is incorrect and this was
    reported in very general error message.
    So I suppose that this error happens only at Polish computers.
    Because any collector related to new 2011.1 SDK has this problem, so i
    suggest to fix the problem.


    --
    steve_zeng
    ------------------------------------------------------------------------
    steve_zeng's Profile: https://forums.netiq.com/member.php?userid=3875
    View this thread: https://forums.netiq.com/showthread.php?t=48077


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •