Hello,

I tried to upgrad our VIBE 3.4 to new Verson 4 how it is explained in documentation.

If I try to start VIBE now I get the following error in catalina.out:

Apr 23, 2015 12:24:08 PM org.apache.catalina.core.StandardService initInternal
SEVERE: Failed to initialize connector [Connector[HTTP/1.1-8443]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8443]]
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:106)
at org.apache.catalina.core.StandardService.initInter nal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.core.StandardServer.initIntern al(StandardServer.java:821)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina .java:638)
at org.apache.catalina.startup.Catalina.load(Catalina .java:663)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:95)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
at org.apache.catalina.startup.Bootstrap.load(Bootstr ap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:454)
Caused by: java.lang.ExceptionInInitializerError
at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:257)
at javax.crypto.KeyAgreement.getInstance(Unknown Source)
at com.ibm.jsse2.L.h(L.java:53)
at com.ibm.jsse2.L.a(L.java:206)
at com.ibm.jsse2.l$c.a(l$c.java:6)
at com.ibm.jsse2.l.a(l.java:90)
at com.ibm.jsse2.m.a(m.java:2)
at com.ibm.jsse2.m.g(m.java:123)
at com.ibm.jsse2.SSLServerSocketFactoryImpl.getSuppor tedCipherSuites(SSLServerSocketFactoryImpl.java:11 )
at org.apache.tomcat.util.net.jsse.JSSESocketFactory. <clinit>(JSSESocketFactory.java:114)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:235)
at org.apache.tomcat.util.net.jsse.JSSEImplementation .getServerSocketFactory(JSSEImplementation.java:47 )
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEnd point.java:388)
at org.apache.tomcat.util.net.AbstractEndpoint.init(A bstractEndpoint.java:646)
at org.apache.coyote.AbstractProtocol.init(AbstractPr otocol.java:434)
at org.apache.coyote.http11.AbstractHttp11JsseProtoco l.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initIntern al(Connector.java:978)
at org.apache.catalina.util.LifecycleBase.init(Lifecy cleBase.java:102)
... 12 more
Caused by: java.lang.SecurityException: Cannot set up certs for trusted CAs
at javax.crypto.b.<clinit>(Unknown Source)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.j ava:235)
... 30 more
Caused by: java.lang.SecurityException: Cannot locate policy or framework files!
at javax.crypto.b.c(Unknown Source)
at javax.crypto.b.access$600(Unknown Source)
at javax.crypto.b$0.run(Unknown Source)
at java.security.AccessController.doPrivileged(Access Controller.java:341)
... 33 more


Java: 1.7 from IBM ink. JCE
Keystore worked in 3.4 before.

Has anybody an idea how I could solve this problem?

Thanks,

Michael