We have setup o365 with NAM. We can successfully login to o365 through
the web service and the desktop apps.

But we get the "AADSTS20001: WS-Federation response does not contain an
issued token" when trying to login in the OneDrive app on iOS and
Android.

I have set the IDP to debug and get the following:


Code:
--------------------
Addition of object com.novell.nidp.servlets.NIDPServletSession@5484af f2 to cache session succeeded using key 4AA6355770F4FBCB36E8E0771E11B7B2. Cache size is 1
</amLogEntry>

<amLogEntry> 2015-05-01T14:38:52Z VERBOSE NIDS Application: Session has consumed authentications: false </amLogEntry>

Added claim http://schemas.microsoft.com/LiveID/...05/ImmutableID
Added claim http://schemas.xmlsoap.org/claims/UPN
<amLogEntry> 2015-05-01T14:38:52Z INFO NIDS Application: AM#500105016: AMDEVICEID#81D5C7A9128B80B5: AMAUTHID#4AA6355770F4FBCB36E8E0771E11B7B2: Processing login resulting from Service Provider authentication request. </amLogEntry>

Warning: Invalid resource key: Authentication error: There is either no 'Local Card' or a 'Provider Card' configured for the requested contract [null]. No prefix!
Warning: Invalid resource key: Authentication error: There is either no 'Local Card' or a 'Provider Card' configured for the requested contract [null]. No prefix!
<amLogEntry> 2015-05-01T14:38:52Z DEBUG NIDS WS Federation:
Method: WSFedSSOProfile.doAuthentication
Thread: ajp-bio-127.0.0.1-9019-exec-1
Authentication error: There is either no 'Local Card' or a 'Provider Card' configured for the requested contract [null] </amLogEntry>

--------------------


I am not sure where to go from there. We have two domains setup for o365
SSO.

This is on Access Manager Appliance 4.1

Mathieu


--
mdallaire
------------------------------------------------------------------------
mdallaire's Profile: https://forums.netiq.com/member.php?userid=3112
View this thread: https://forums.netiq.com/showthread.php?t=53419