I had two issues trying to do a clean install of 2.6 using Postgres
installed on a linux server.

Firstly, when I came to configure the database I received an error
message and the setup failed. The fix was relatively simple. It involved
editing the /opt/PostgreSQL/9.4/data/pg_hba.conf file to add an extra
line allowing connections from my server range

# "local" is for Unix domain socket connections only
local all all md5
# IPv4 local connections:
host all all md5
# IPv6 local connections:
host all all ::1/128 md5
# Network Servers
host all all xx.xx.xx.xx/24 md5

After that, the configuration worked. I didn't have this issue with 2.5
when I was testing it.

My second issue was that I was unable to download a licence file. Even
though I copied and pasted the key from the 2.6 reporter area of the
Customer Service Portal, I was told it was an invalid key. I remember I
had the same issue when testing 2.5 last year not long after it was
released. I got distracted and didn't get back to testing until
recently, and I was then able to download a licence successfully. So,
some timing thing? I've sent an email to customerresolution@novell.com
and downloaded and eval licence for now.