I have SLES 11 SP1 and Novell Data Synchronizer 1.2.4 build 966. I would like to know what would be the best update path to take?

SP1 -> SP2 -> SP3 first?

Also Can I upgrade from 1.2.4 to directly to GroupWise Mobility Service 2.1? I see the readme for 2.0 indicates that upgrade an option.