I believe I have made a mess. I have an existing old Netware server currently running DNS. I have 3 OES11 servers all running DHCP with no issues there. I tried to create a new DNS server on one of the OES servers, and that's where the fun began....

Apparently in the course of setting up the last DHCP server, I wacked the "real" DNS-DHCP locator object (used by both Netware & OES DNS but not dhcp anymore). So now, my DNS domain & hosts don't appear in the java console anymore. The Netware DNS continues to tick along - until it restarts.... So, I attempted to create a DNS server on one of the OES11 servers, which created a new DNS-DHCP object. But creating the new DNS server in Yast, I get an error (error configuring DNS). The rcnovell-named does start, but I am unable to create any servers or zones in the java console.

When I try to create a primary zone, it insists I enter the nameserver host name - but the -only- available zone is RootSrvInfo. When I try to create a server, same issue - only Rootsrvino is available, not my "real" domain.
If I go to the DNS-DHCP object to manually try and enter the zone for DNIP:DNSZones (per TID 7012947), I get NDS error -613 (incorrect value, or value pointing to on object that doesn't exist). I -do- see my domain object (mydomain.net) in iManager, and all 5,000+ hosts there (ddns entries mostly). Is there a way to reconnect this to DNS?

I actually don't mind re-creating my domain - there are only 30 or so hosts I really need. Is there a way to totally start over with DNS? Remove and try and reinstall? At some point in this upgrade process I did have a dns server showing up in the console, but I can't remember what happened to it. Can someone shed some light on either 1) how to create the server or zone in the console, or 2) how to start over without screwing up DHCP or the existing (although unconfigurable now) netware DNS, or 3) how to re-associate my domain in the tree with DNS?


I'll post /var/opt/novell/log/named/named.run below.


tia-
Suzie


19-Jul-2015 18:48:54.728 general: main: notice: starting BIND 9.3.2 -u named
19-Jul-2015 18:48:54.782 general: server: info: found 16 CPUs, using 16 worker threads
19-Jul-2015 18:48:56.320 general: dns/db: critical: Failed to load RRs of rootserver zone with error -603
19-Jul-2015 18:48:56.320 general: dns/hints: warning: Loading Root data from directory Failed
19-Jul-2015 18:48:56.321 general: server: info: loading configuration from '/etc/opt/novell/named/named.conf'
19-Jul-2015 18:48:56.490 network: interfacemgr: info: listening on IPv4 interface lo, 127.0.0.1#53
19-Jul-2015 18:48:56.501 network: interfacemgr: error: binding TCP socket: address in use
19-Jul-2015 18:48:56.501 network: interfacemgr: info: listening on IPv4 interface lo, 127.0.0.2#53
19-Jul-2015 18:48:56.501 network: interfacemgr: error: binding TCP socket: address in use
19-Jul-2015 18:48:56.501 network: interfacemgr: info: listening on IPv4 interface eth0, 10.30.64.3#53
19-Jul-2015 18:48:56.502 network: interfacemgr: error: binding TCP socket: address in use
19-Jul-2015 18:48:56.548 general: dns/db: error: Unable to set an attribute[(null)] in eDirectory with error 70
19-Jul-2015 18:48:56.548 network: interfacemgr: error: Error occured while updating the IP list of the DNS server object:70
19-Jul-2015 18:48:56.549 general: control: notice: couldn't add command channel 127.0.0.1#953: address in use
19-Jul-2015 18:48:56.757 general: dns/db: error: Unable to get Journal Log attribute or SOA sr. no. with error 70
19-Jul-2015 18:48:56.973 general: dns/zone: info: zone 64.30.10.IN-ADDR.ARPA/IN: loaded serial 2015071711
19-Jul-2015 18:48:57.202 general: dns/db: error: Unable to get Journal Log attribute or SOA sr. no. with error 70
19-Jul-2015 18:48:57.203 general: dns/zone: info: zone merkel.esc14.net/IN: loaded serial 2015071801
19-Jul-2015 18:48:57.203 general: server: notice: running