Hi,

we have a JDBC driver. A few weeks ago, the driver starts without any
problems. And now when we want to start the JDBC driver we get the
following message in the logfile

[07/24/15 11:21:28.467]:RoleDM PT:java.lang.UnsatisfiedLinkError: no
ocijdbc11 in java.library.path
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at
oracle.jdbc.driver.T2CConnection$1.run(T2CConnecti on.java:3560)
at java.security.AccessController.doPrivileged(Native Method)
at
oracle.jdbc.driver.T2CConnection.loadNativeLibrary (T2CConnection.java:3556)
at
oracle.jdbc.driver.T2CConnection.logon(T2CConnecti on.java:269)
at
oracle.jdbc.driver.PhysicalConnection.<init>(Physi calConnection.java:553)
at
oracle.jdbc.driver.T2CConnection.<init>(T2CConnect ion.java:165)
at
oracle.jdbc.driver.T2CDriverExtension.getConnectio n(T2CDriverExtension.java:53)
at
oracle.jdbc.driver.OracleDriver.connect(OracleDriv er.java:528)
at java.sql.DriverManager.getConnection(Unknown Source)
at java.sql.DriverManager.getConnection(Unknown Source)
at
com.novell.nds.dirxml.driver.jdbc.util.connect.JDB CConnectionImpl.newConnection(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.util.connect.JDB CConnectionImpl.setConnection(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.util.connect.JDB CConnectionImpl.open(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.util.connect.JDB CConnectionManager.newConnection(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.util.connect.JDB CConnectionManager.newPublicationConnection(Unknow n
Source)
at
com.novell.nds.dirxml.driver.jdbc.JDBCPublicationS him.initialConnect(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.JDBCPublicationS him.start(Unknown
Source)
at
com.novell.nds.dirxml.driver.jdbc.JDBCPublicationP roxy.start(Unknown
Source)
at
com.novell.nds.dirxml.engine.Publisher.run(Publish er.java:542)
at java.lang.Thread.run(Unknown Source)

.....

Status: Fatal
Message: Code(-9021) The drivers publisher shim returned before
the driver was instructed to shut down.


Do you have any ideas? What can we do to start the driver correctly?

bestregards,
fhgmika


--
fhgmika
------------------------------------------------------------------------
fhgmika's Profile: https://forums.netiq.com/member.php?userid=313
View this thread: https://forums.netiq.com/showthread.php?t=53923