Hello,

I have an IDM 4.5.1 solution running on Linux with a SOAP 4.0.0.3
driver. It is running with a remote loader.

When an event passes through the driver on the subscriber channel, the
event is a success and the data is sent to the remote system over the
webservice. But, after the event has passed through and the webservices
reponds with success, I get this error:


Code:
--------------------

<SOAP:Body>
<SOAP:Fault>
<faultcode>SOAP:Server</faultcode>
<faultstring>Server Error</faultstring>
<detail>
<s:SystemError xmlns:s="http://sap.com/xi/WebService/xi2.0">
<context>XIAdapter</context>
<code>ADAPTER.JAVA_EXCEPTION</code>
<text>
com.sap.engine.interfaces.messaging.api.exception. MessagingException: com.sap.engine.interfaces.messaging.api.e
xception.MessagingException: XIServer:CX_RD_PLSRV:
at com.sap.aii.adapter.soap.ejb.XISOAPAdapterBean.pro cess(XISOAPAdapterBean.java:1184)
at sun.reflect.GeneratedMethodAccessor320.invoke(Unkn own Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:592)
...

--------------------


This is my NOVLDSML-DSMLOutputTransform:

http://pastebin.com/WZifh9Bx

This is a full trace of an event:

http://pastebin.com/NjhEK53P

I think there might be missing something in my XSD document, but I do
not know what.

Any ideas?

Jacob.


--
jacmarpet
------------------------------------------------------------------------
jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=53989