I was really happy to see Chrome support for the iprint plugin. But it's using the npapi which is deprecated and doesn't work in chrome version 42 and higher.

I can't understand why Novell uses a deprecated api to make a plugin when google accounced in sept 2013 that it would drop npapi.