In the latest Firefox when I try to browse to my Vibe (3.4) server I get the following error:

Error code: ssl_error_weak_server_ephemeral_dh_key

In researching the error it seems to be tied to the Logjam vulnerability.

How do I fix this to secure the server? I've read some steps related to Apache settings but I'm not that familiar with where they should go on a Vibe server.

Dan Pearson