i have Problem installing vibe 4.0 hp3 on a actual sles11sp4

Question: run vibe4 hp3 on sles11sp4?

where can i find the correct sdk for ibm (prefered) or Oracle working with sles11sp4?

by installing Oracle Version with rpm -ivh jdk-8u51-Linux-x64.rpm following error Pop up:
error: Failed dependencies: /usr/sbin/alternatives is needed by jdk1.8.0_51-1.8.0_51-fcs.x86_64

what can i do?
what must i install for Oracle JDK?
what must i install for Ibm SDK?
what is the best tool?