Home

Results 1 to 4 of 4

Thread: WebAccess Java High CPU

  1. #1
    Join Date
    Aug 2008
    Posts
    120

    WebAccess Java High CPU

    We are running a GroupWise 2014 SP2 system on an OES 11 SP2 server.

    After a couple weeks Java runs at 175% CPU and requires restarting novell-tomcat6.

    How and where would I make the changes so Java / Tomcat operate with Xms1024m and Xmx4096m settings?

    Also with those settings is an export in the script required.

    Other posts indicate these settings need to be applied to /etc/opt/novell/tomcat6/conf/novell-tomcat6.conf file.

    When I make those settings in the conf file how do I determine whether or not they are effective?

    Thanks, Dave.

  2. #2
    Join Date
    Jan 2010
    Location
    Toronto, Canada, Planet Earth, (originally from Montreal)
    Posts
    2,416

    Re: WebAccess Java High CPU

    In article <dkerbaugh.745han@no-mx.forums.microfocus.com>, Dkerbaugh
    wrote:
    > How and where would I make the changes so Java / Tomcat operate with
    > Xms1024m and Xmx4096m settings?
    >
    > Also with those settings is an export in the script required.
    >
    > Other posts indicate these settings need to be applied to
    > /etc/opt/novell/tomcat6/conf/novell-tomcat6.conf file.


    We confirm which instance of tomcat is being used.
    ps aux | grep tomcat
    in which we see several folders looking for the highest version, with
    Novell ones being 'higher' than non-Novell ones.
    In the example I am looking at (GW2012.3 on OES11.2) I see a few
    instances of /var/opt/novell/tomcat6 as the highest version. To confirm
    that this is running
    rcnovell-tomcat6 status
    if that is the case, then the config file you referred to is correct.
    After you've made the changes
    rcnovell-tomcat6 restart
    ps eaf | grep java
    should now show the -Xms and -Xmx settings which I see doesn't show for
    unmodified/default systems.


    Also see an earlier thread for more on this for different perspectives
    https://forums.novell.com/showthread...memory-is-too-
    low-error-on-GroupWise-WebAccess-2014


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!


  3. #3
    Join Date
    Aug 2008
    Posts
    120

    Re: WebAccess Java High CPU

    I did confirm that novell-tomcat6 loads at startup versus tomcat6.

    I entered the following in /etc/opt/novell/conf/novell-tomcat6.conf file:
    CATALINA_OPTS="-Xthr:minimizeUserCPU -Xms2048M -Xmx4096M"

    After restarting, (rcnovell-tomcat6), I do see the new parameters.

    Brainshare 2014 PDF recommended the -Xms2048M -Xmx4096M do I need to be concerned with garbage collection parameters?

    Also, would you be so kind to explain what effect the following parameter in the conf file would have:
    JAVA_OPTS="-Xminf0.1 -Xmaxf0.3"

    Thank you for your help!

  4. #4
    Join Date
    Jan 2010
    Location
    Toronto, Canada, Planet Earth, (originally from Montreal)
    Posts
    2,416

    Re: WebAccess Java High CPU

    In article <dkerbaugh.74clbb@no-mx.forums.microfocus.com>, Dkerbaugh
    wrote:
    > After restarting, (rcnovell-tomcat6), I do see the new parameters.

    Often for max benefit, a full reboot will be needed at some point.

    > Brainshare 2014 PDF recommended the -Xms2048M -Xmx4096M do I need to be
    > concerned with garbage collection parameters?

    Those are the numbers I would go with as well assuming system RAM is 6GB+
    I have never had to dig into the garbage collection side, so I can't help
    you with JAVA_OPTS. If you do some tests with JAVA_OPTS, do let us know
    the results you see.


    Andy of
    http://KonecnyConsulting.ca in Toronto
    Knowledge Partner
    http://forums.novell.com/member.php/75037-konecnya
    If you find a post helpful and are logged in the Web interface, please
    show your appreciation by clicking on the star below. Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •