Home

Results 1 to 6 of 6

Thread: Managed system gateway driver port error

  1. #1
    Join Date
    Jan 2015
    Posts
    20

    Managed system gateway driver port error


    Hi there,

    We are experiencing some issues with the managed system gateway driver.
    The driver seem to be stopping at random and is then unable to start.
    From the logging is seems that port 9000, on which this driver listens,
    is already in use. So in other words, the driver restarts and still
    claims the port. On the start of the driver there is a fatal error which
    states that the port is already in use.

    Netstat shows the following:

    netstat -talpn | grep 9000
    tcp 0 0 :::9000 :::*
    LISTEN -

    Is it not in use by a process. A restart of ndsd fixes the issue but
    this does not seem like normal behaviour. Does anyone else experience
    this issue?


    --
    nickvandermeijde
    ------------------------------------------------------------------------
    nickvandermeijde's Profile: https://forums.netiq.com/member.php?userid=8288
    View this thread: https://forums.netiq.com/showthread.php?t=54400


  2. #2

    Re: Managed system gateway driver port error

    What does the output from the following show when this happens (with the
    appropriate port entered in for the 'grep' command)?

    Code:
    /usr/sbin/ss -planeto | grep :9000
    I've seen issues at some point in the past where sockets would get stuck
    open, so perhaps that is related to your issue since bouncing ndsd seems
    to help.

    Another test you could try is unloading vrdim (the IDM module within
    eDirectory) and then restarting that to see if that will, more-subtly,
    clean up the stock socket, since I would guess that IDM itself is holding
    open the socket.

    Code:
    ndstrace
    unload vrdim
    load vrdim
    Which version of eDirectory are you using, and which version of IDM
    (patches too for both, please)? Is this SLES 11, I presume, or could it
    be SLES 10, or RedHat something-or-another?

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    Jan 2015
    Posts
    20

    Re: Managed system gateway driver port error


    ab;261320 Wrote:
    > What does the output from the following show when this happens (with
    > the
    > appropriate port entered in for the 'grep' command)?
    >
    > >

    Code:
    --------------------
    > >

    > /usr/sbin/ss -planeto | grep :9000
    >

    --------------------
    > >

    >
    > I've seen issues at some point in the past where sockets would get
    > stuck
    > open, so perhaps that is related to your issue since bouncing ndsd
    > seems
    > to help.
    >
    > Another test you could try is unloading vrdim (the IDM module within
    > eDirectory) and then restarting that to see if that will,
    > more-subtly,
    > clean up the stock socket, since I would guess that IDM itself is
    > holding
    > open the socket.
    >
    > >

    Code:
    --------------------
    > >

    > ndstrace
    > unload vrdim
    > load vrdim
    >

    --------------------
    > >

    >
    > Which version of eDirectory are you using, and which version of IDM
    > (patches too for both, please)? Is this SLES 11, I presume, or could
    > it
    > be SLES 10, or RedHat something-or-another?
    >
    > --
    > Good luck.
    >
    > If you find this post helpful and are logged into the web interface,
    > show your appreciation and click on the star below...


    We are using IDM 4.5 on eDir 8.8 with no additional patches installed.
    This is installed on a RHEL 6.6 server. The output of the sockstat is:

    LISTEN 0 50 :::9000
    :::* ino:313651 sk:ffff8802369ea080
    CLOSE-WAIT 353 0 ::ffff:10.2.0.64:9000
    ::ffff:10.2.0.64:47061 users("ndsd",2029,429)) ino:12211
    sk:ffff880239b8a0c0


    --
    nickvandermeijde
    ------------------------------------------------------------------------
    nickvandermeijde's Profile: https://forums.netiq.com/member.php?userid=8288
    View this thread: https://forums.netiq.com/showthread.php?t=54400


  4. #4

    Re: Managed system gateway driver port error

    On 10/05/2015 05:44 AM, nickvandermeijde wrote:
    >
    > We are using IDM 4.5 on eDir 8.8 with no additional patches installed.
    > This is installed on a RHEL 6.6 server. The output of the sockstat is:
    >
    > LISTEN 0 50 :::9000
    > :::* ino:313651 sk:ffff8802369ea080
    > CLOSE-WAIT 353 0 ::ffff:10.2.0.64:9000
    > ::ffff:10.2.0.64:47061 users("ndsd",2029,429)) ino:12211
    > sk:ffff880239b8a0c0


    IDM 4.5 requires at least eDirectory 8.8 SP8; are you sure that is not
    what you are on already? Running 'ndsstat' should tell you in a
    human-friendly way, or else you can query the RPM database for the exact
    answer:

    Code:
    rpm -qa | grep NDSserv
    It looks like, at this point, you have a connection still waiting for a
    full closure. A CLOSE-WAIT can last a while, and is caused until the
    server-side of the connection-close (meaning the side that did not
    initially decide to close the socket) finishes what it is doing and
    releases the socket; it is up to the application there to finish up the
    work and close, and until then things remain as you see them, which may be
    the issue for you.

    Does IDM show the driver config object as stopped, or in shutdown pending?
    Any luck with the vrdim option?

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  5. #5
    djgulik NNTP User

    Re: Managed system gateway driver port error


    Hi ab,

    we are using 8.8 SP8 with IDM4.5. The vrdim option doesn't solve the
    issue.
    So the only option we have is a ndsd restart? This is not what we want
    because this issue occurs frequently.

    Any other ideas?


    --
    djgulik
    ------------------------------------------------------------------------
    djgulik's Profile: https://forums.netiq.com/member.php?userid=9410
    View this thread: https://forums.netiq.com/showthread.php?t=54400


  6. #6

    Re: Managed system gateway driver port error

    Apply patches. SP1 is out, and SP2 will likely come out very soon. Also,
    eDirectory 8.8 SP8 has had six major patche releases, the last one last
    week. I'd apply all of those to see if it helps. Be sure after patching
    IDM to the latest SP that you also apply any MSGW driver specific patches.

    After you are patched, open a Service Request (SR) with NetIQ if the
    problem persists.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •