I actually figured it out myself by looking at Twilio's test pages. In
case someone else needs to know, this worked for me.

NOTE: If a setting isn't listed here, I left it at the default.

1. Log into twilio with your admin user.

2. Click on *Get API credentials* (currently in the upper right)

3. Log into SSPR as an administrative user and open the Configuration

4. Click on *SMS Gateway* (under SMS, on the left.)

5. If necessary, change the *SMS Destination Address LDAP Attribute*. (I
changed mine to "mobile")

6. From the Twilio page displaying the API Credentials, copy the
*ACCOUNT SID* and paste it into *SMS Gateway User* on the SMS settings

7. From the Twilio page displaying the API Credentials, copy the *AUTH
TOKEN* and paste the into the *SMS Gateway Password* field.

8. Your *SMS Gateway* will be

https://api.twilio.com/2010-04-01/Accounts/*YOUR ACCOUNT SID

So if your Account SID is n0nSenseStr1ng, your message gateway would be

9. *HTTP(S) Method* should be "POST".

10. *SMS Gateway Authentication Method* should be "HTTP - Use HTTP Basic

11. The *SMS Request Data* should be


12. *SMS Sender ID*: Enter the phone number from Twilio, using the
format +12223334567 (with the plus sign being the important bit.)

Note that this is for a trial Twilio account. It is probably
possible to have an alphanumeric identifier here with a "real" account,
but, for now we have the trial one. And until I changed this to the
actual sending number, it didn't work.

13. *SMS Phone Number Format*: Change to "Plus - Same as plain, but with
a plus sign as a prefix: +112312345"

14. *SMS Data Content Encoding*: I used "XML - for XML and/or SOAP
services" but I think JSON would also work.

15. *Successful HTTP Result Codes*: To avoid an error message, click
*Add Value* and enter *201* (Twilio's success code.)

There is a button at the top to test the settings.

Good luck!
Karla B

kborecky's Profile: https://forums.netiq.com/member.php?userid=6280
View this thread: https://forums.netiq.com/showthread.php?t=54561