Hi there! I searched the forum and couldn't find an answer.

We're developing an interface to Groupwise 2014 in java, and using the latest schemas from the SDK. I'm trying to create an appointment and mark it as private, this is the SOAP message that is being sent to the server and its response:

Code:
<?xml version='1.0' encoding='UTF-8'?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
	<S:Header>
		<session xmlns="http://schemas.novell.com/2005/01/GroupWise/types"
			xmlns:ns2="http://schemas.novell.com/2005/01/GroupWise/methods"
			xmlns:ns3="http://schemas.novell.com/2005/01/GroupWise/events">AEQv7WZgpfKSo3RF</session>
		<gwTrace xmlns="http://schemas.novell.com/2005/01/GroupWise/types"
			xmlns:ns2="http://schemas.novell.com/2005/01/GroupWise/methods"
			xmlns:ns3="http://schemas.novell.com/2005/01/GroupWise/events">true</gwTrace>
	</S:Header>
	<S:Body>
		<ns2:createItemRequest
			xmlns="http://schemas.novell.com/2005/01/GroupWise/types" xmlns:ns2="http://schemas.novell.com/2005/01/GroupWise/methods"
			xmlns:ns3="http://schemas.novell.com/2005/01/GroupWise/events">
			<ns2:item xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
				xsi:type="Appointment">
				<status>
					<private>true</private>
				</status>
				<subject>TEST SUBJECT</subject>
				<startDate>2010-06-01T00:00:00.000+02:00</startDate>
				<endDate>2010-06-30T00:00:00.000+02:00</endDate>
				<place>I love spring</place>
			</ns2:item>
		</ns2:createItemRequest>
	</S:Body>
</S:Envelope>
 
<?xml version="1.0" encoding="UTF-8"?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
	<S:Header />
	<S:Body>
		<gwm:createItemResponse
			xmlns:gwm="http://schemas.novell.com/2005/01/GroupWise/methods"
			xmlns:gwt="http://schemas.novell.com/2005/01/GroupWise/types"
			xmlns:gwe="http://schemas.novell.com/2005/01/GroupWise/events">
			<gwm:id>564C90DD.MyDomain.MyPO.100.168356D.1.98.1@4:7.MyDomain.MyPO.100.0.1.0.1@16
			</gwm:id>
			<gwm:status>
				<gwt:code>0</gwt:code>
			</gwm:status>
		</gwm:createItemResponse>
	</S:Body>
</S:Envelope>
But when I try to get back the same Item it's not marked private, this is the response from the server:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/">
	<S:Header />
	<S:Body>
		<gwm:getItemResponse
			xmlns:gwm="http://schemas.novell.com/2005/01/GroupWise/methods"
			xmlns:gwt="http://schemas.novell.com/2005/01/GroupWise/types"
			xmlns:gwe="http://schemas.novell.com/2005/01/GroupWise/events">
			<gwm:item xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
				xsi:type="gwt:Appointment">
				<gwt:id>564C90DD.MyDomain.MyPO.100.168356D.1.98.1@4:7.MyDomain.MyPO.100.0.1.0.1@16
				</gwt:id>
				<gwt:version>1</gwt:version>
				<gwt:modified>2015-11-18T21:53:17Z</gwt:modified>
				<gwt:container>A.MyDomain.MyPO.100.0.1.0.1@19</gwt:container>
				<gwt:created>2015-11-18T21:53:17Z</gwt:created>
				<gwt:status>
					<gwt:accepted>1</gwt:accepted>
					<gwt:opened>1</gwt:opened>
					<gwt:read>1</gwt:read>
				</gwt:status>
				<gwt:msgId>564C90DD.MyDomain.MyPO.100.168356D.1.98.1</gwt:msgId>
				<gwt:source>personal</gwt:source>
				<gwt:delivered>2015-11-18T21:53:18Z</gwt:delivered>
				<gwt:security>Normal</gwt:security>
				<gwt:subject>TEST SUBJECT</gwt:subject>
				<gwt:distribution>
					<gwt:from>
						<gwt:displayName>wef</gwt:displayName>
						<gwt:email>wef@groupwise2014</gwt:email>
						<gwt:uuid>0E06F990-0DE5-0000-816D-796462643566</gwt:uuid>
					</gwt:from>
					<gwt:sendoptions>
						<gwt:statusTracking>All</gwt:statusTracking>
					</gwt:sendoptions>
				</gwt:distribution>
				<gwt:options>
					<gwt:priority>Standard</gwt:priority>
				</gwt:options>
				<gwt:size>256</gwt:size>
				<gwt:iCalId>2015-11-18T21:53:17Z_3B490095@wdgroupwise2014
				</gwt:iCalId>
				<gwt:startDate>2010-05-31T22:00:00Z</gwt:startDate>
				<gwt:endDate>2010-06-29T22:00:00Z</gwt:endDate>
				<gwt:acceptLevel>Busy</gwt:acceptLevel>
				<gwt:alarm enabled="1">300</gwt:alarm>
				<gwt:place>I love spring</gwt:place>
			</gwm:item>
			<gwm:status>
				<gwt:code>0</gwt:code>
			</gwm:status>
		</gwm:getItemResponse>
	</S:Body>
</S:Envelope>
I haven't tried setting the private attribute with markPrivateRequest, but I don't want to make two calls to the server if it's not needed. Am I doing something wrong here?
Thanks in advance!