I have IDM 4.5.2 running on SLES 11 SP4 and trying to read a GCV on the
UA driver from a from an integration activity, but it just returns null.


I have added these values to the User App Driver...

UserApplication :Multiple definition found for Global Config Value
'UAProvURL'. Using definition from
\GLWF\ENT\Services\DriverSetAE\UserApplication.
UserApplication :Multiple definition found for Global Config Value
'service-account-dn'. Using definition from
\GLWF\ENT\Services\DriverSetAE\UserApplication.
UserApplication :Multiple definition found for Global Config Value
'service-account-pswd'. Using definition from
\GLWF\ENT\Services\DriverSetAE\UserApplication.

When looking at the catalina.out ....

DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] evaluating
source expression: GCV.getValueForNamedPassword('service-account-pswd')
DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] result:
null
DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] evaluating
source expression: GCV.get('UAProvURL') + "/role/service"
DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] result:
null/role/service
DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] evaluating
source expression: GCV.get('service-account-dn')
DEBUG com.novell.soa.af.impl.core.DataItemEvaluator- [RBPM] result:
null

How does the UserApplication read the GCV? Via the User App Driver? Via
LDAP? Where else can I look to see why it will not read the values.

Thanks in Advance


--
rjreisbi
------------------------------------------------------------------------
rjreisbi's Profile: https://forums.netiq.com/member.php?userid=2906
View this thread: https://forums.netiq.com/showthread.php?t=55165