We have setup kerberos authenication for our windows 7 zcm clients.
The zcm server is loaded with the keytab created on our domain controller the following way:
The zcm server is also not a member of the domain.

ktpass /princ host/zcm01.stellingwerfcollege.nl@STELLINGWERFCOLLEGE.N L -pass ********* -mapuser zcm01 -out zcm01.keytab -mapOp set -ptype KRB5_NT_PRINCIPAL

zcm01.stellingwerfcollege.nl = the hostname of the zcm server.
zcm01 is also the user created in active directory
This is the only ktpass syntax that works all other generates errors in the ATS.log server side.

However at the clients kerberos authenication is not working. In the client log the following error is found:

[DEBUG] [03/17/2016 10:08:58.855] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [GetAuthMechToken Entered] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.857] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [Mech Info SVC_PRINCIPAL=host/zcm01.stellingwerfcollege.nl] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.857] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [Mech Info REALM_CREDENTIALS_ONLY=true] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.857] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [Authsource service principal : host/zcm01.stellingwerfcollege.nl] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.857] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [LUID Created HighPart : 0 Low Part :2821906] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.859] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [Acquired the Credential Handle for the LUID :2821906] [] [] [] [ZENworks Agent]
[DEBUG] [03/17/2016 10:08:58.866] [1264] [ZenworksWindowsService] [47] [] [KerberosAuthMechanismHandler] [] [Exception Message :System.Exception: Failed to get the client token Return Status : -2146893053

The server logs are error free, What could be causing this error?