I have a Vibe 3.4 server running on 32 bit SLES10sp4 / OES2 sp3 which started life as a Teaming v2 starter pack virtual machine, so its installed in /home/icecore .....

I want to move the site to 64 bit OES2015 on SLES11sp3 and the docs suggest I have 2 options:

1) Upgrade in place 3.4 to 4.0.1, then move the database dump
- this requires Oracle JDK upgrade from 1.6 to 1.7, then vibe upgrade
- this failed with "HTTP Status 500 - Error creating bean with name 'sPropsUtil' defined in ServletContext resource" which I could not resolve

2) Install Vibe 3.4 on new server, migrate database, upgrade to Vibe 4.0.1
- cannot get a new install to work successfully on new server, always end up with Error 404

I have to say, hundreds of pages of docs and no clear step by step guide, very frustrating. Followed by incomprehensible pages of error messages

any suggestions as to whether option 1 or 2 is the better to persevere with?

Is it even worth the pain? ;-)