Hi All,

Had a working test environment running IDM 4.5.0 and been patching it
up to 4.5.3. All was working before patching and eDir/IDM engine/RBPM
patched just fine. After patching OSP/SSPR (that are running on their
own tomcat on RH 6.5) whenever I run /etc/init.d/idmapps_tomcat_init
start the catalina.out shows the following error:

2016-05-07 15:28:02,932 [main] INFO
org.apache.catalina.core.AprLifecycleListener- The APR based Apache
Tomcat Native library which allows optimal performance in production
environments was not found on the java.library.path:
2016-05-07 15:28:03,344 [main] INFO
org.apache.coyote.http11.Http11Protocol- Initializing ProtocolHandler
2016-05-07 15:28:03,364 [main] INFO org.apache.coyote.ajp.AjpProtocol-
Initializing ProtocolHandler ["ajp-bio-8009"]
2016-05-07 15:28:03,367 [main] INFO
org.apache.catalina.startup.Catalina- Initialization processed in 928 ms
2016-05-07 15:28:03,408 [main] INFO
org.apache.catalina.core.StandardService- Starting service Catalina
2016-05-07 15:28:03,408 [main] INFO
org.apache.catalina.core.StandardEngine- Starting Servlet Engine: Apache
2016-05-07 15:28:03,447 [localhost-startStop-1] INFO
org.apache.catalina.startup.HostConfig- Deploying web application
archive /netIQ/idm/apps/tomcat/webapps/osp.war
Starting initialization of device 250627a2-f063-4ffe-bdb3-94a8fbaa54c2
using server version: 6.0.0 r3 February 4 2016 11:10:49
MobaXterm X11 proxy: Unsupported authorisation protocol
[OSP] 2016-05-07T15:28:06.884-0700
Level: FATAL
Code: com.novell.osp.servlet.OSPContextListener.contextI nitialized()
[93] thread=localhost-startStop-1
Critical Startup Error:
Exception Class: java.awt.AWTError
Can't connect to X11 window server using 'localhost:10.0' as the
value of the DISPLAY variable.
Stack Trace:
Can't connect to X11 window server using 'localhost:10.0' as the
value of the DISPLAY variable.
sun.awt.X11GraphicsEnvironment: X11GraphicsEnvironment.java:
initDisplay: -2
sun.awt.X11GraphicsEnvironment: X11GraphicsEnvironment.java:
access$200: 65
sun.awt.X11GraphicsEnvironment$1: X11GraphicsEnvironment.java: run: 115
java.security.AccessController: AccessController.java: doPrivileged: -2
sun.awt.X11GraphicsEnvironment: X11GraphicsEnvironment.java:
<clinit>: 74

2016-05-07 15:28:07,146 [localhost-startStop-1] INFO
org.apache.catalina.startup.HostConfig- Deployment of web application
archive /netIQ/idm/apps/tomcat/webapps/osp.war has finished in 3,699 ms

I followed the steps from
https://dl.netiq.com/Download?buildid=O5ptOLoXiDY~ and already compared
md5sum with the files from the patch and cleared webapps/osp, work and
temp multiple times at no avail.

Anyone ever saw that before or know where to look for the issue? I can
only assume it tried to load a window due to some issue, however I am
accessing a server remotely and said server does not have a local GUI
installed. X11 forwarding does work for configupdate in the very same setup.