Hello,
i just installed latest patch "IDM 4.5 bidirectional eDir Driver Version 4.0.2.0 " and I am having some issues with changelog, After installing it, the eDirectory is not able to start and keep running. In ndsd.log i can see "Loader Failed:for /opt/novell/eDirectory/lib64/nds-modules/libdxevent.so,error libdirxml.so.3: cannot open shared object file: No such file or directory,errno 2"


I explored novell-DXMLChlgx and found out:
Code:
rpm -ql novell-DXMLChlgx
/opt/novell/eDirectory/bin/clutil
/opt/novell/eDirectory/lib
/opt/novell/eDirectory/lib/clutil.jar
/opt/novell/eDirectory/lib/ldap.jar
/opt/novell/eDirectory/lib64/libdirxml.so.3.0.500 <--- loooks interesting to me
/opt/novell/eDirectory/lib64/nds-modules/libcldxevent.la
/opt/novell/eDirectory/lib64/nds-modules/libcldxevent.so.3
/opt/novell/eDirectory/lib64/nds-modules/libcldxevent.so.3.0.0
/opt/novell/eDirectory/lib64/nds-modules/libdxevent.so
/opt/novell/eDirectory/lib64/nds-modules/libxclldap.la
/opt/novell/eDirectory/lib64/nds-modules/libxclldap.so
/opt/novell/eDirectory/lib64/nds-modules/libxclldap.so.3
/opt/novell/eDirectory/lib64/nds-modules/libxclldap.so.3.0.0
/opt/novell/eDirectory/lib64/nds-schema/clschema.sch

I tried to symlink /opt/novell/eDirectory/lib64/libdirxml.so.3.0.500 to /opt/novell/eDirectory/lib64/libdirxml.so.3 and it changed things. ndsd is able to start, it works and synchronizes again. So this seems like the problem is fixed. But I am wondering, if this is the proper way to fix "it". Is this a known issue or I missed something? Did anybody else experienced it? I followed the readme_5241950.html while installing it.