I have recently had certificates expire on one of our services.

Ive tried to recreate the services using the certificate creation method.

3 seem to be created ok but I do not get the fourth

rob36:/software # ndsconfig upgrade

[1] Instance at /etc/opt/novell/eDirectory/conf/nds.conf: rob36.OU=OESSERVERS.OU=MAIN.OU=SH.O=ROBSON.GEO_ROB SON

Upgrading NetIQ eDirectory server with the following parameters, Please wait...
Tree Name : GEO_ROBSON

Configuration File : /etc/opt/novell/eDirectory/conf/nds.conf
Instance Location : /var/opt/novell/eDirectory/data
DIB Location : /var/opt/novell/eDirectory/data/dib

Checking if server is ready to service requests... Done
Enter admin name with context[admin.org]:admin.robson
Enter the password for admin.robson:

Performing eDirectory health check...
WARNING: Errors were detected during the server health check.
Continue (y/n)? y
For more details view health check logfile: /var/opt/novell/eDirectory/log/ndscheck.log

Extending schema... Done
For more details view schema extension logfile: /var/opt/novell/eDirectory/log/schema.log

Configuring HTTP service... Done
Configuring LDAP service... Done
Configuring SNMP service... Done
Configuring SAS service... Failed to configure SAS service: unknown error -1222 (fffffb3a hex) err=-1222
An error has occured while configuring the NetIQ eDirectory Server. Please look /var/opt/novell/eDirectory/log/ndsd.log file for more information.

The instance at /etc/opt/novell/eDirectory/conf/nds.conf is upgraded successfully.

Ive looked around on these forums for a few hours and came across some mention of crl s. Our crl shows CRL_3 and ONE. I have tried deleting ONE and recreating the certificates but ONE reappears. Im not sure if this is a re herring or not.

any help would be much appreciated