Hi,

I am testing running eDir (and eventually IDM) off of a shared disk following the documentation here . I built a 3 node cluster using SLES 12 SP1 with the HA extension.

After the initial configuration of eDir, providing a virtual NCP server name and IP address, the instance started and stopped without issue. I ran the nds-cluster-config, and while it warned of an unsupported OS, it appeared to finish successfully.

Now when running ndsmanage startall, I received the error below and it appears from the ndsd.log that the instance is starting but then shuts down as if systemctl did not detect it in a running state. See below.

jscdidv201:/opt/novell/eDirectory/bin # ndsmanage startall
Server instances management utility for NetIQ eDirectory 8.8 SP8 v20808.02
Instance at /etc/opt/novell/eDirectory/conf/nds.conf.....
Starting NetIQ eDirectory server...
Job for ndsdtmpl-etc-opt-novell-eDirectory-c...onf-env.service failed. See "systemctl status ndsdtmpl-etc-opt-novell-eDirectory-c...onf-env.service" and "journalctl -xn" for details.

Below is the output of "systemctl status"

jscdidv201:/opt/novell/eDirectory/bin # systemctl status ndsdtmpl-etc-opt-novell-eDirectory-c...onf-env.service - eDirectory service for /etc/opt/novell/eDirectory/conf/env
Loaded: loaded (/usr/lib/systemd/system/ndsdtmpl-etc-opt-novell-eDirectory-conf-nds.conf@.service; enabled)
Active: failed (Result: timeout) since Fri 2016-05-13 08:44:48 EDT; 23min ago
Process: 19756 ExecStopPost=//opt/novell/eDirectory/sbin/post_ndsd_stop_factory (code=exited, status=0/SUCCESS)
Process: 19754 ExecStopPost=//opt/novell/eDirectory/sbin/post_ndsd_stop_custom (code=exited, status=0/SUCCESS)
Process: 18784 ExecStartPost=//opt/novell/eDirectory/sbin/post_ndsd_start_factory (code=exited, status=0/SUCCESS)
Process: 18782 ExecStartPost=//opt/novell/eDirectory/sbin/post_ndsd_start_custom (code=exited, status=0/SUCCESS)
Process: 18778 ExecStart=/opt/novell/eDirectory/sbin/ndsdwrapper (code=exited, status=0/SUCCESS)
Process: 18776 ExecStartPre=//opt/novell/eDirectory/sbin/pre_ndsd_start_factory (code=exited, status=0/SUCCESS)
Process: 18775 ExecStartPre=//opt/novell/eDirectory/sbin/pre_ndsd_start_custom (code=exited, status=0/SUCCESS)
Main PID: 1276 (code=exited, status=0/SUCCESS)

May 13 08:42:46 jscdidv201 post_ndsd_start_factory[18784]: NetIQ eDirectory LDAP Server is listening on the TCP port.
May 13 08:42:46 jscdidv201 post_ndsd_start_factory[18784]: NetIQ eDirectory LDAP Server is listening on the TLS port.
May 13 08:44:13 jscdidv201 systemd[1]: ndsdtmpl-etc-opt-novell-eDirectory-c...onf-env.service start-...topping.
May 13 08:44:48 jscdidv201 systemd[1]: Failed to start eDirectory service for /etc/opt/novell/eDirectory/conf/env.
Hint: Some lines were ellipsized, use -l to show in full.
jscdidv201:/opt/novell/eDirectory/bin #

It appears to me that systemctl is not getting the appropriate signal that the instance is running however, looking at the ndsd.log it appears to start and then is told to terminate.

May 13 08:42:43 Path of NetIQ eDirectory configuration file /etc/opt/novell/eDirectory/conf/nds.conf
May 13 08:42:43 Host process for NetIQ eDirectory 8.8 SP8 v20808.02 successfully started
May 13 08:42:43 DHLog: file size 1048576
[ -- DHost Logging STARTED Fri May 13 08:42:43 2016 -- ]
May 13 08:42:43 MASV Init called
May 13 08:42:43 Mandatory Access Control Service Version: 8.8.8.1 started
May 13 08:42:43 NMAS Server Version:8.8.8.7 Build:20160111 started
May 13 08:42:43 SPM DClient Version:8.8.8.7 Build:20160111 started
May 13 08:42:43 MASV Init called
May 13 08:42:43 MASV already initialized.
Loader Failed:for dxevent,error dxevent: cannot open shared object file: No such file or directory,errno 2
May 13 08:42:44 GAMS Init called
May 13 08:42:44 Graded Authentication Management Service Version: 8.8.8.1 started
May 13 08:42:44 Information: SNMP Trap Server for NetIQ eDirectory 8.8.8 v20808.02 started.

May 13 08:42:45 NDS iMonitor for NetIQ eDirectory 8.8 SP8 v20808.02 started successfully.
May 13 08:42:45 Loading SecretStore Server...
May 13 08:42:45 NetIQ SecretStore Service Version 8.8.8.1 Loaded Successfully
May 13 08:42:45 Loading SecretStore LDAP Transport Plugin...
May 13 08:42:45 NetIQ SecretStore LDAP Plugin Version 8.8.8.1 Loaded Successfully.
May 13 08:42:45 SecretStore LDAP Extension Handler Loaded Successfully
May 13 08:42:45 NMAS Server Version:8.8.8.7 Build:20160111 started
May 13 08:42:45 SPM DClient already started (2)
May 13 08:42:45 LDAP Agent for NetIQ eDirectory 8.8 SP8 (20808.06) started
May 13 08:42:45 SASL Version:8.8.8.7 Build:20160111 started
We are in DHost.
May 13 08:42:45 NetIQ PKI Services Started Successfully
May 13 08:42:45 PKIHealth.log in directory: /mnt/idv-ds1a-fs/eDirectory/log/
May 13 08:42:56 Loading SecretStore NCP Transport Plugin...
May 13 08:42:56 NetIQ SecretStore NCP Plugin Version 8.8.8.1 Loaded Successfully.
May 13 08:44:13 Got SIGINT/SIGTERM signal, server shutting down
May 13 08:44:13 Unloading SSNCP...
May 13 08:44:13 SecretStore NCP Plugin Unloaded Successfully
May 13 08:44:14 NetIQ PKI Services unloaded
May 13 08:44:14 SPM DClient closed
May 13 08:44:17 NDS iMonitor for NetIQ eDirectory 8.8 SP8 v20808.02 shutdown successfully.
May 13 08:44:19 Unloading SSLDP...
May 13 08:44:19 SecretStore LDAP Plugin Unloaded Successfully
May 13 08:44:19 SecretStore LDAP Extension Handler Unloaded
May 13 08:44:19 LDAP Agent for NetIQ eDirectory 8.8 SP8 (20808.06) stopped
May 13 08:44:19 Information: SNMP Trap Server for NetIQ eDirectory 8.8.8 v20808.02 stopped.

May 13 08:44:19 GAMS closed
May 13 08:44:36 MASV closed
[ -- DHost Logging STOPPED Fri May 13 08:44:37 2016 -- ]
May 13 08:44:43 SASL closed


Any ideas on why the systemctl does not detect the instance as running?

Thanks,

Jeff