I used to check gwdom.dc and gwpo.dc for versions, they both say version 1420, is this the correct version for gw2014 r2 hp1?