Hello All;

I have SLES 11 SP3 with OES 2015 (no SP). NSS storage which works from a NWClient.

Now trying to get Novell-Samba working. Configured through OES-Install with no issues. I can run an 'id admin' and other users which returns each users uid and gid.

But when I start samba with 'rcsmb start', smb starts but with an ldap error.
May 31 16:42:59 nss-fs1 /usr/sbin/namcd[6557]: searchAndFillPwdStruct_fromNDS: Error [87] in LDAP search while trying to fill passwd structure : filter=uid=nss-fs1\root,base=o=nss

The server nss-fs1 is in ou=novell,dc=nss,dc=local

DFSW is not installed

So whiat an I missing?

here is the relevent smb.conf
ldap ssl = no
workgroup = workgroup
passdb backend = NDS_ldapsam:ldaps://
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = Yes

# BEGIN - Entries made by OES install
netbios name = nss-fs1-W
ldap admin dn = cn=nss-fs1-sambaProxy,ou=novell,dc=nss,dc=local
ldap suffix = ou=novell,dc=nss,dc=local
ldap passwd sync = on
security = user
encrypt passwords = yes

# NOTE: use sendfile is set to no to support nss filesystem shares.
# To improve performance for other filesystems that support
# sendfile remove this line from the global section and add only
# to share definitions on nss filesystems.
use sendfile = no
server string =

# END - Entries made by OES install

Any suggestions?

In the end, I would like to have the NSS volume clustered with Novell Samba running for the non-NWClient users.
I have the NSS volume clustered. Now to get Novell-Samba added to the load resource but run into this issue and the users cannlt auth to samba via ldap.