Have been meaning to patch our Vibe 4.0.0 installation at least to HP4 but we seem to have an odd build number installed, see below:

Novell Vibe Administration
Release: Novell Vibe 4.0.0
Build: 4199 / 18 September 2015

Yet in the HP4 patch notes I find the pre-requisites are:

System Requirements:
This patch is provided as a complete Novell Vibe 4.0 installer and can be used for:
(a) Patching an existing Vibe 4.0 installation
(b) Setting up a new Vibe 4.0 installation
(c) Updating an existing Vibe 3.x or a Teaming 2.x installation

For (a), please ensure that your site is currently running ANY one of the following builds:
Novell Vibe 4.0.0 (Build 4193 / April 5, 2015)
Novell Vibe 4.0.0 (Build 4207 / June 11, 2015)
Novell Vibe 4.0.0 (Build 4217 / July 13, 2015)
Novell Vibe 4.0.0 (Build 4218 / July 27, 2015)

and for the java update:

This patch must only be applied to a site that is currently on
Novell Vibe 4.0.0 (Build 4225 / September 18, 2015)

Which I'm assuming is the build of HP4?

The file we installed from and downloaded from the Novell Website was:
novell-vibe-4.0.0-linux.tar on 9th December 2015 - MD5: e9349610321e5982dea26f952550aac6

So two questions: what version are we really running? and is it safe to upgrade to HP4 and the java updates thereafter?