I am about to upgrade our two servers to 11.4.2 This is a school and the vast majority of workstations are at 11.3.2, Can I assume the older agent will be ok until we upgrade to the 11.4.2 agent?

I've read that the supported versions are:

v10.3.4 and later versions is supported on Windows but I am just checking. The last thing I need on Monday is hundreds of windows stations not working. :-)