I want to determine the po-software version and not the database version before I login with soap into the mailbox with the correct schema version.

I know I can see it after login with soap, but then I have to login twice.

Is there an option in the admin api?

e.g. GW4014R2SP1 has database version 1420 and software version 14.2.1.

In the soap for 14.2.1 there are a few new options, but you have to set the schema version you want.